Return to the Electrical Wiring Forum | Post a Follow-Up

 o
Under cabinet light not working

Posted by baileyandbella (My Page) on
Thu, Sep 9, 10 at 13:38

We have fluorescent under cabinet lighting installed by the builder. One of the lights stopped working, and I thought it was the light bulb, but it wasn't.

My husband nor I have any electrical experience. Is this something maybe we can fix ourselves or should we hire out?

Thanks


Follow-Up Postings:

 o
RE: Under cabinet light not working

Then it's likely the ballast (most modern fixtures don't have starters). Replacing a ballast isn't the most difficult task in the world but it does take some basic understanding of how to make electrical connections.

Depending on the cost of replacement, it may be cheaper to just toss the old one and buy a new one.


 o
RE: Under cabinet light not working

Would a new one be easy to install? Do I need to get the same type again?

Thanks


 o
RE: Under cabinet light not working

A ballast isn't difficult to install, as long as you replace it with exactly the same type.

However, I'd hate to see you spend $20 or so on a new ballast, and still not have a working light. I say this because it's also possible that one or both of the sockets (also called cleats or tombstones) that the ends of the lamp (tube) fit into has (or have) gone bad.

You can replace those too, of course, for a few more dollars. And that might be a plan.

Turn off the breaker powering these lights before you do anything!

Remove any lens on the fixture, then the lamp (tube). Then remove the metal cover - this may require removing a couple of screws or pushing in a couple of metal tabs. You might have to crane your neck to see up there, or hop up on the counter.

Before you go any further, look at the wiring for any connections that look darkened or charred. Wiggle things around. At this point you may consider briefly putting the lamp back in and turning the power on. Sometimes, if you have a loose connection, moving it will fix the problem temporarily. If that's the case, come back here and we'll tell you how to fix it for good.

Assuming that didn't work, shut off the breaker again.

For the next step it may help to unscrew the fixture from the bottom of the cabinet. Otherwise you can again do a little acrobatics.

Take a series of clear, closeup color pictures of what's inside the fixture. Take those pictures to a good electrical supply store or an old fashioned hardware store, where they have counter people who actually know something about electrical work. They should be able to provide you with a new ballast and sockets. They may even wire up the new ballast to the sockets for you if you ask nicely.

Also buy a few wire nuts. They can show you how they work for making connections to the new "guts" for the fixture.

If all this sounds complicated, now you know why electricians are in demand. :)

Good luck! If you get stuck, come back and we'll try to help you further.


 o
RE: Under cabinet light not working

It is often cheaper to purchase a replacement fixture rather than just a ballast.

If the repair fails at least you have a spare fixture.


 o
RE: Under cabinet light not working

We have under cabinet lights connected to a light switch. i noticed yesterday that they don't turn on anymore. It can't be all the bulbs went at once so there must be an issue somewhere...any suggestions?


 o
RE: Under cabinet light not working

Could be anything from the switch itself, the wiring, the ballast, etc.

Without some basic electrical tools you are left with just a visual check of the wiring, or swapping out the switch.

If the switch is 'push wired' from the back check the connections (after turning off the breaker) to make sure the wires are still tight.
You should then probably move them to under the screws as long as you have the switch out of the box.


 o Post a Follow-Up

Please Note: Only registered members are able to post messages to this forum.

    If you are a member, please log in.

    If you aren't yet a member, join now!


Return to the Electrical Wiring Forum

Information about Posting

  • You must be logged in to post a message. Once you are logged in, a posting window will appear at the bottom of the messages. If you are not a member, please register for an account.
  • Posting is a two-step process. Once you have composed your message, you will be taken to the preview page. You will then have a chance to review your post, make changes and upload photos.
  • After posting your message, you may need to refresh the forum page in order to see it.
  • Before posting copyrighted material, please read about Copyright and Fair Use.
  • We have a strict no-advertising policy!
  • If you would like to practice posting or uploading photos, please visit our Test forum.
  • If you need assistance, please Contact Us and we will be happy to help.


Learn more about in-text links on this page here