Return to the Electrical Wiring Forum | Post a Follow-Up

 o
Rheostat for a 11000 watt kitchen blender

Posted by pristin (My Page) on
Tue, Jan 31, 12 at 12:01

I am trying to adapt a KITCHEN BLENDER (like a Waring Blender) for use in a small laboratory where we develop TOPICAL creams. The low speed on the blender is TOO HIGH for making the cream and it destroys the cream matrix. I was wondering if I can hook up a RHEOSTAT to do this. Please help answering and also the kind of Rheostat I should use. Thanks


Follow-Up Postings:

 o
RE: Rheostat for a 11000 watt kitchen blender

The few blenders I have inspected closely have a "universal" motor which does work properly with a rheostat. The power to that motor is through the controls on the blender. But the controls on the blender may not work properly with the output from any external control device.
Your post cannot be correct on the wattage.
A rheostat is a variable resistor and simply wastes the unused electricity as heat- a crude way to do it. Using a variable transformer directly to the motor, bypassing the original controls, is a much better way. Running the motor at slower speeds risks overheating no matter how the speed control is accomplished.


 o
RE: Rheostat for a 11000 watt kitchen blender

If it has a universal motor any of the drill/router speed control

Here is a link that might be useful: http://www.amazon.com/MLCS-9410-20-Amp-Router-Control/dp/B001NIK6PC/ref=pd_sim_sbs_k_2


 o
RE: Rheostat for a 11000 watt kitchen blender

If the blender already has a speed control it is not going to work well with another control feeding it.


 o
RE: Rheostat for a 11000 watt kitchen blender

Just set the blender at MAX speed and it should be ok.


 o
RE: Rheostat for a 11000 watt kitchen blender

There is proper laboratory equipment that will do what you need. Check for paddle mixers and homogenizers of various types. You can probably find a used one for a good price if you shop around. You may well get lucky on ebay. I get some lab equipment there.


 o Post a Follow-Up

Please Note: Only registered members are able to post messages to this forum.

    If you are a member, please log in.

    If you aren't yet a member, join now!


Return to the Electrical Wiring Forum

Information about Posting

  • You must be logged in to post a message. Once you are logged in, a posting window will appear at the bottom of the messages. If you are not a member, please register for an account.
  • Posting is a two-step process. Once you have composed your message, you will be taken to the preview page. You will then have a chance to review your post, make changes and upload photos.
  • After posting your message, you may need to refresh the forum page in order to see it.
  • Before posting copyrighted material, please read about Copyright and Fair Use.
  • We have a strict no-advertising policy!
  • If you would like to practice posting or uploading photos, please visit our Test forum.
  • If you need assistance, please Contact Us and we will be happy to help.


Learn more about in-text links on this page here