Return to the Stained Glass & Mosaics Forum | Post a Follow-Up

 o
Glue Problem

Posted by katishooked (My Page) on
Sun, Aug 10, 08 at 20:51

I made 2 bb with glass globs using loctite clear silicone adhesive sealant. I first sanded the balls, then painted then glued globs on. Both balls are losing the globs. Whatever is the problem here. I've used this glue on mushrooms and they are doing fine. I sure would like to find a glue to use for inside AND outside. This is killing my desire to to want to make mosaics for gifts. Sure don't want gifts falling apart. What a disaster that would be.

Kathy


Follow-Up Postings:

 o
RE: Glue Problem

My guess would be the paint may have caused this.
So sorry to hear that happened to you. It's really upsetting, I know. I quit doing outside stuff a while ago.


 o Post a Follow-Up

Please Note: Only registered members are able to post messages to this forum.

    If you are a member, please log in.

    If you aren't yet a member, join now!


Return to the Stained Glass & Mosaics Forum

Information about Posting

  • You must be logged in to post a message. Once you are logged in, a posting window will appear at the bottom of the messages. If you are not a member, please register for an account.
  • Posting is a two-step process. Once you have composed your message, you will be taken to the preview page. You will then have a chance to review your post, make changes and upload photos.
  • After posting your message, you may need to refresh the forum page in order to see it.
  • Before posting copyrighted material, please read about Copyright and Fair Use.
  • We have a strict no-advertising policy!
  • If you would like to practice posting or uploading photos, please visit our Test forum.
  • If you need assistance, please Contact Us and we will be happy to help.


Learn more about in-text links on this page here