Return to the Sewing Forum | Post a Follow-Up

 o
interesting tidbit about Janome.com

Posted by birdtalker (My Page) on
Sat, Nov 22, 08 at 17:46

I left a message on the Contact Us page of Janome.com. I answered all their questions in order to post. Afterwards I got the usual message thanking me for posting, saying my message had been sent. A moment later I got a message from my Internet provider that said the message was undeliverable. That the system had been set up to bounce back and forth between two email addresses. Sounds to me like they do not read, or want to read, comments from customers. Next machine I get WILL NOT BE A JANOME.


Follow-Up Postings:

 o
RE: interesting tidbit about Janome.com

I read your post, and decided to email them.

I got the first notification within seconds, and then a reply within about an hour. No problems whatsoever.


 o Post a Follow-Up

Please Note: Only registered members are able to post messages to this forum.

    If you are a member, please log in.

    If you aren't yet a member, join now!


Return to the Sewing Forum

Information about Posting

  • You must be logged in to post a message. Once you are logged in, a posting window will appear at the bottom of the messages. If you are not a member, please register for an account.
  • Posting is a two-step process. Once you have composed your message, you will be taken to the preview page. You will then have a chance to review your post, make changes and upload photos.
  • After posting your message, you may need to refresh the forum page in order to see it.
  • Before posting copyrighted material, please read about Copyright and Fair Use.
  • We have a strict no-advertising policy!
  • If you would like to practice posting or uploading photos, please visit our Test forum.
  • If you need assistance, please Contact Us and we will be happy to help.


Learn more about in-text links on this page here