Return to the Home Repair Forum | Post a Follow-Up

 o
Craftsman 1/2hp Garage Door Opener

Posted by box211 (My Page) on
Mon, Dec 14, 09 at 14:28

I have had a 1/2hp Craftsman garage door opener for several years. It suddenly does not work and seems to have no power, but when I tap or hold in the back panel the light comes on and it will operate for a few seconds. I took off the back panel to see if there were any loose wires, but it all looks good. Any ideas on how to fix this???


Follow-Up Postings:

 o
RE: Craftsman 1/2hp Garage Door Opener

I would pull that back panel. Attached to it is the logic board. Check the printed circuit for loose or missing traces especially around the small transformer.


 o Post a Follow-Up

Please Note: Only registered members are able to post messages to this forum.

    If you are a member, please log in.

    If you aren't yet a member, join now!


Return to the Home Repair Forum

Information about Posting

  • You must be logged in to post a message. Once you are logged in, a posting window will appear at the bottom of the messages. If you are not a member, please register for an account.
  • Please review our Rules of Play before posting.
  • Posting is a two-step process. Once you have composed your message, you will be taken to the preview page. You will then have a chance to review your post, make changes and upload photos.
  • After posting your message, you may need to refresh the forum page in order to see it.
  • Before posting copyrighted material, please read about Copyright and Fair Use.
  • We have a strict no-advertising policy!
  • If you would like to practice posting or uploading photos, please visit our Test forum.
  • If you need assistance, please Contact Us and we will be happy to help.


Learn more about in-text links on this page here