Return to the Pools & Spas Forum | Post a Follow-Up

 o
Rust in filter housing? Photo attached.

Posted by goyom (My Page) on
Sun, Aug 29, 10 at 13:22

I am hoping someone can shed some light on this.

I took apart my filter housing yesterday to clean my cartridge filters and noticed this rust inside. Is this highly unusual? My pool was completed in April this year.
This is a Jandy CL 460. This photo is from the inside.

Photobucket
Thanks for any input.


Follow-Up Postings:

 o
RE: Rust in filter housing? Photo attached.

Got Saltwater?


 o
RE: Rust in filter housing? Photo attached.

I do have salt water, I wouldnt think this should happen, since the filter housing is supposed to be made for saltwater use ?


 o
RE: Rust in filter housing? Photo attached.

Unfortunately one of the problems with salt water systems.


 o
RE: Rust in filter housing? Photo attached.

Stainless comes in a number of grades. Some are a bit more expensive and more resistant. Doesn't look like this grade was used for this application. I doubt that Jandy is aware of this situation. They should be notified so they can take corrective measures.

Scott


 o
RE: Rust in filter housing? Photo attached.

Looks just like my Pentair filer :(


 o
RE: Rust in filter housing? Photo attached.

Electrolysis is a weird problem nobody had a perfect detection method, nor resolution for it. It doesn't effect all pools, and equipment the same. I'm sure this isn't an issue of a lower grade metal getting past Jandy, it's a electrolytic issue with this pool in particular.


 o
RE: Rust in filter housing? Photo attached.

neilaz, which filter and where are you seeing it?

Scott


 o
RE: Rust in filter housing? Photo attached.

Good luck finding a stainless belt on any filter that doesn't have a little bit of rust on it.
This is very common and I wouldn't sweat over it at all.
When I clean my filters I ignore this and reassemble.

See ya,
Kelly


 o
RE: Rust in filter housing? Photo attached.

Clean and Clear plus. I would post a picture but it looks just like goyom's only a little more since mine is 5 yrs old.


 o
RE: Rust in filter housing? Photo attached.

So - here it is, 2014 and I have the same exact problem on a brand new pool. I would think that Jandy, Pentair or whichever name you bought ( they all work under same manufacturers ) would have worked this out already. I'm about to send my pics back to the pool co. that installed it 5 months ago. Any updates????


 o Post a Follow-Up

Please Note: Only registered members are able to post messages to this forum.

    If you are a member, please log in.

    If you aren't yet a member, join now!


Return to the Pools & Spas Forum

Information about Posting

  • You must be logged in to post a message. Once you are logged in, a posting window will appear at the bottom of the messages. If you are not a member, please register for an account.
  • Posting is a two-step process. Once you have composed your message, you will be taken to the preview page. You will then have a chance to review your post, make changes and upload photos.
  • After posting your message, you may need to refresh the forum page in order to see it.
  • Before posting copyrighted material, please read about Copyright and Fair Use.
  • We have a strict no-advertising policy!
  • If you would like to practice posting or uploading photos, please visit our Test forum.
  • If you need assistance, please Contact Us and we will be happy to help.


Learn more about in-text links on this page here