Return to the Pools & Spas Forum | Post a Follow-Up

 o
Intellichlor / Easytouch question

Posted by flhomes (My Page) on
Wed, Jul 25, 12 at 10:58

I'm finally 30 days into my pool redo and just converted to salt. For the past 30 days I have been happy with my Easytouch configured with the following schedules:

User Function1 = Pool Cleaner (automated valve) = sandshark runs 1 hour per day, pump at 2500 rpm
User Function2 = Pool Low = runs 9 hours per day, pump at 1000 rpm
Pool Mode = Pool High = manual only when we want more "action" when present at poolside, pump at 2200rpm, this is activated by pushing the "P" on the wireless controller, easy for wife & kids.

The pump is direct wired...power always on...Easy touch controlls settings
I just wired the Intellichlor to be power always on thinking it's internal flow switch will turn it on/off and EasyTouch will control settings. The pump relay is not used. It seems EasyTouch is not smart enough to realize the pump is running in "pool low" mode even though it is the one turning it on. It will not activate the Intellichlor in Pool Low mode. It will only activate Intellichlor during "pool" mode (renamed pool high).

Am I missing something? Do I need to reconfigure and change pool high and pool low? Doing this makes is confusing for wife/kids to turn on pool high manually from the wireless controller.

As a side comment, I find it amazing that such antiquated 1980's technology is this expensive and unconfigurable. I am finding that the wireless 8 button controller is about useless as the 8 buttons cannot be programmed to use functions. They are effectively "hardwired" to the relays. I find this system quite amazing in a negative way.


Follow-Up Postings:

 o
RE: Intellichlor / Easytouch question

I take it your Easytouch isn't one which has the internal power center. The Easy Touch has a 4 wire terminal for the Intelliflow pump and the power center does too. Run a quad wire per the manual between the two. The one in the Easy Touch can handle the two.

The flow switch may not close at the low speed with your plumbing. Try using 1200 rpm instead.

Which wireless? It sounds like a configuration issue and someone isn't as familiar with the options as they should be. Your needs are not that complex from what I can see.

Scott


 o
RE: Intellichlor / Easytouch question

Thanks for the reply. My Easytouch does have integrated powercenter for IntelliChlor. I didn't wire the Intellichlor transformer through the pump transformer, which means the chlorinator always has power.


 o
RE: Intellichlor / Easytouch question

Funny - so if I setup my expensive Easytouch to "disable" the chlorinator, then adjust % on the chlorinator itself, it works like I want. The chlorinator starts working on it's own whenever it detects flow without any instruction from the "automation" system. Turns out, the chlorinator is smarter than the automation system. The not-so-automation Easytouch system doesn't know when it turns the pump on to be able to turn on the chlorinator.

Only disadvantage is I can only manage in 20% increments. My dissatisfaction with this "automation" system grows. Dang...X10 technology is outdated, but I think that would have been a better choice over this Easytouch system, from both cost and functionality perspective.

I have to wonder if Pentair severely crippled and dumbed down the controller system for fear that the average installer doesn't know anything about computer technology. If that is the case, I don't think that is a good assessment of the average pool installer (at least those I've talked to). I didn't look much at competitor systems, but one of the others has to be more modern, flexible, and cost effective.


 o
RE: Intellichlor / Easytouch question

flhomes... I feel your pain. After 4 years of having an Intelliflow pump, an Intellichlor 40, heater, and a separate pump for my infinity edge, I finally found a technician that fully understands the pump and the Intellitouch control panel. No one I bought out to the house knew more than I did about the set up. Even when I called Pentair directly and told them to refer me to a tech that knew their product... still no luck. Only after today do I finally have my system 100% automated. Thanks much Tim Puff.


 o Post a Follow-Up

Please Note: Only registered members are able to post messages to this forum.

    If you are a member, please log in.

    If you aren't yet a member, join now!


Return to the Pools & Spas Forum

Information about Posting

  • You must be logged in to post a message. Once you are logged in, a posting window will appear at the bottom of the messages. If you are not a member, please register for an account.
  • Please review our Rules of Play before posting.
  • Posting is a two-step process. Once you have composed your message, you will be taken to the preview page. You will then have a chance to review your post, make changes and upload photos.
  • After posting your message, you may need to refresh the forum page in order to see it.
  • Before posting copyrighted material, please read about Copyright and Fair Use.
  • We have a strict no-advertising policy!
  • If you would like to practice posting or uploading photos, please visit our Test forum.
  • If you need assistance, please Contact Us and we will be happy to help.


Learn more about in-text links on this page here