Return to the Pools & Spas Forum | Post a Follow-Up

 o
Intex Pool Issues...Algae and pump.

Posted by rowlf914 (My Page) on
Sat, Jun 5, 10 at 14:15

Okay, I'm a first time pool owner, and I'm making mistakes...guess this is the season I learn from, and all of the rest I will enjoy....LOL

Anyway, I have an Intex Easyset 15 foot x 42 inch pool. The first issue is that I have had nothing but problems with algae this year. I've shocked twice and it keeps coming back. Today I've added an algaecide and have been cleaning the filter every hour or so. The water appears to be clearing up a bit, and as I skim the top I'm getting residue on my skimmer net so something is working. Is there anything else I should be doing for the algae problem?

My second problem...the filter pump seems to be pretty noisy, and I keep seeing air bubbles in the outlet hose. This is a 1000 GPM Krystal Klear pump. I am priming it properly, and have checked the hoses for leaks and have found none and the o-ring seals on both hoses, the top housing, and the air-purge cap are okay. I need to run the pump to help the algae problem, so is there anything else I need to look at on the pump


Follow-Up Postings:

 o
RE: Intex Pool Issues...Algae and pump.

Well I got both problems fixed...I think. I algaecided the pool yesterday and did the vacuum thing, and it's cleared up quite a bit. Still a bit cloudy, but that should resolve in a couple of days. The pump problem turned out to be that I was not properly purging the air....I was not letting all of the air out of the pump. Now I have no air bubbles, and almost clear water. I guess I won!!!!


 o
RE: Intex Pool Issues...Algae and pump.

Visit www.troublefreepools.com for learning about pool chemistry in the pool school section.

Scott


 o
RE: Intex Pool Issues...Algae and pump.

Thanks for following up and posting the fix (the need to purge the air out), saves me time searching around for an answer.

Here is a link that might be useful: Intex 637R fix


 o
RE: Intex Pool Issues...Algae and pump.

We have an Intex pool (although I love this forum because a pool is on top of my list of wants). I use Clorox bleach as my source of chlorine, and never use anything else, and do not have any issues. Water stays crystal clear.


 o Post a Follow-Up

Please Note: Only registered members are able to post messages to this forum.

    If you are a member, please log in.

    If you aren't yet a member, join now!


Return to the Pools & Spas Forum

Information about Posting

  • You must be logged in to post a message. Once you are logged in, a posting window will appear at the bottom of the messages. If you are not a member, please register for an account.
  • Please review our Rules of Play before posting.
  • Posting is a two-step process. Once you have composed your message, you will be taken to the preview page. You will then have a chance to review your post, make changes and upload photos.
  • After posting your message, you may need to refresh the forum page in order to see it.
  • Before posting copyrighted material, please read about Copyright and Fair Use.
  • We have a strict no-advertising policy!
  • If you would like to practice posting or uploading photos, please visit our Test forum.
  • If you need assistance, please Contact Us and we will be happy to help.


Learn more about in-text links on this page here