Return to the Pools & Spas Forum | Post a Follow-Up

 o
Minimax NT TSI heater

Posted by davsiz (My Page) on
Mon, Apr 11, 11 at 12:50

I have a MiniMax NT TSI gas heater, HTR-400-NT-STD-PH. It was installed August 2005. On the DDTC, only the power and pressure sw led's work. The SPA light is also lit up. Everything else is blank and not responding to inputs. I reset the circuit breaker. No luck. Any other ideas or suggestions for trouble shooting? Am I in need if a new DDTC?
Thanks.


Follow-Up Postings:

 o
RE: Minimax NT TSI heater

chances are, yes. Especially if there is nothing coming out on the LED display.


 o
RE: Minimax NT TSI heater

The current temperature will display. However, nothing changes regardless of which buttons are pressed. Is there anything else that could cause this sort of problem other that the DDTC?


 o
RE: Minimax NT TSI heater

Sounds like a ddtc issue to me.


 o Post a Follow-Up

Please Note: Only registered members are able to post messages to this forum.

    If you are a member, please log in.

    If you aren't yet a member, join now!


Return to the Pools & Spas Forum

Information about Posting

  • You must be logged in to post a message. Once you are logged in, a posting window will appear at the bottom of the messages. If you are not a member, please register for an account.
  • Please review our Rules of Play before posting.
  • Posting is a two-step process. Once you have composed your message, you will be taken to the preview page. You will then have a chance to review your post, make changes and upload photos.
  • After posting your message, you may need to refresh the forum page in order to see it.
  • Before posting copyrighted material, please read about Copyright and Fair Use.
  • We have a strict no-advertising policy!
  • If you would like to practice posting or uploading photos, please visit our Test forum.
  • If you need assistance, please Contact Us and we will be happy to help.


Learn more about in-text links on this page here