Return to the Pools & Spas Forum | Post a Follow-Up

 o
Spa jets: 1 like a firehose, 3 barely blowing

Posted by desertmarc (My Page) on
Tue, Mar 29, 11 at 21:24

One of my spa jets is blowing like a champion, and the other three are barely blowing.

I have an in-ground pool/spa. I checked the openings of the jets, and they are all clear.

I have a 1 1/2 horespower pump for my spa.

My pool is running at 15 (PSI?), so I know my filter could use a little cleaning.

My spa pressure guage (if its working correctly )says 15 (PSI?).

I opened the spa suction and return. I diverted the water flow to the spa.

It's been a while since I used the spa.

Any suggestions on where to start.


Follow-Up Postings:

 o
RE: Spa jets: 1 like a firehose, 3 barely blowing

That does sound like the pressure gauge is not reading correctly. Most systems will show an increase in tank pressure when the spa is on, especially on a 4 jet system where 3 appear to be weaker.

Did this suddenly start happening?

Is the one jet that is the champion drawing air too?

If you were to lower the spa's water level to just below the jet height, is the champ is still the champ or are they now equal?

Is your pool new? Did you have the pool built? Is this a concrete pool, liner pool, or fiberglass?

Scott


 o
RE: Spa jets: 1 like a firehose, 3 barely blowing

My "DE Filter" pressure guage usually goes up 10 psi above its normal operating level, as soon as I divert the water flow over to the spa.

I don't recall how things were before, but I can't imagine I would have been satisifed with the performance when only 1 of the 4 jets were blowing strong.

Hopefully this info helps. I appreciate any suggestions!

Thank you.

My pool/spa is concrete and 20 years old.


 o
RE: Spa jets: 1 like a firehose, 3 barely blowing

Drop the water level to just under the jets' level. Then put it in spa mode. You should see 4 equal streams. If one of the streams is more of a gush, shut off the pump and look inside the jets. Each jet, assuming they are the most common type, should have a nozzle that looks like a white tube. I suspect one is missing it's tube.

Scott


 o
RE: Spa jets: 1 like a firehose, 3 barely blowing

How did you check that the spa jets are clear. Did you remove the nozzels with a tool?
Is it possible the "Champ"s nozzel fell out, thus making the others suffer.


 o
RE: Spa jets: 1 like a firehose, 3 barely blowing-

Sorry Scott,
I didnt read your post, I think you nailed it as well.
Great minds think alike.


 o
RE: Spa jets: 1 like a firehose, 3 barely blowing

Thank you all very much for your response.

Turns out one of the orifaces / nozzles broke off and was laying on the bottom of the spa. Without the resistance, all the water was rushing out of the one jet.

I'm hoping the oriface / nozzle fully came off from the jet, so all I have to do is put a new one on.

Thanks again!


 o
RE: Spa jets: 1 like a firehose, 3 barely blowing

They thread in. "Gently" tapping a flat head screw driver so it's edges bite the inside wall of the remaining piece should allow you to remove the remaining piece.

Scott


 o
RE: Spa jets: low water flow and almost no air

Just had the pool and spa remodelled. broke out all old plumbing in spa and replaced with new. Also New DE filter, etc. everything was pressure tested before applying new pebble plaster - (a mess and plenty of debris).
the 4 spa jets are pulling almost no air at all and the water flow seems much weaker than before any construction. The old nozzles looked like tiny starfish that could be aimed and screwed open or closed to change the flow (I think) but the new ones are just open holes big enough for my index finger. I thought that was the problem but contractor said those aren't available anymore, etc. He added a blower motor which barely helped the flow and still only 2 of the 4 are emitting any air. It seems like the jets (behind the nozzles) are likely clogged - right ?
if they even used jets at all...how do I remove and clean them out - or replace if that's the diagnosis ?
Thanks !!


 o
RE: Spa jets: 1 like a firehose, 3 barely blowing

Did you get any pix of the demo work?

Scott


 o Post a Follow-Up

Please Note: Only registered members are able to post messages to this forum.

    If you are a member, please log in.

    If you aren't yet a member, join now!


Return to the Pools & Spas Forum

Information about Posting

  • You must be logged in to post a message. Once you are logged in, a posting window will appear at the bottom of the messages. If you are not a member, please register for an account.
  • Please review our Rules of Play before posting.
  • Posting is a two-step process. Once you have composed your message, you will be taken to the preview page. You will then have a chance to review your post, make changes and upload photos.
  • After posting your message, you may need to refresh the forum page in order to see it.
  • Before posting copyrighted material, please read about Copyright and Fair Use.
  • We have a strict no-advertising policy!
  • If you would like to practice posting or uploading photos, please visit our Test forum.
  • If you need assistance, please Contact Us and we will be happy to help.


Learn more about in-text links on this page here