Return to the Pools & Spas Forum | Post a Follow-Up

 o
Pentair Minimax NT E004

Posted by JMarko (My Page) on
Sat, Mar 16, 13 at 16:14

I have replaced the upper plenum, fan, pressure switch, ignitor, flame sensor, and I cleaned all 8 burners of dirt dobbers and rust. The heater worked a few times and now one month later I again get error code 004 after it tries to cycle on 4-5 times. After the purge cycle, the fan shuts off for about 15 seconds and then I hear the fuel gas ignite. When the fan does not turn back on shortly after ignition, the fuel gas trips off. After 4-5 times, I get the E004 code. Can someone tell me what to do to get this problem fixed. I do not see anything wrong with the hose. Also, I cleaned the burner valve as best I could.


Follow-Up Postings:

 o
RE: Pentair Minimax NT E04

After reading several of the other posts with similar problems, I again cleaned out all the burners and orifices. I also replaced the hose to the fan/ pressure switch just in case there was a small hole. I just put it all back together and still get the same problem. The gas trips off shortly after it lights because the fan does not switch from low speed to high speed quickly enough. Any suggestions for the next step. I was thinking it may be the controller (expensive item) or possibly the Honeywell gas valve.


 o
RE: Pentair Minimax NT E004

Have you called Pentair?


 o
RE: Pentair Minimax NT E004

Check the stack flue sensor.....


 o
RE: Pentair Minimax NT E004

I don't see any stack flue sensor in the manual. I don't think this model has one.


 o
RE: Pentair Minimax NT E004

I guess I was thinking of a Master temp...Sorry...Try the link below

Here is a link that might be useful: Pentair


 o
RE: Pentair Minimax NT E004

Thanks, I will check that link. Last weekend, I got the heater running by lowering the fuel gas pressure at the manifold by turning the adjustment counterclockwise inside the valve. I went in 1/4 increments until the heater started. I then ordered a 0-15" wc gauge so that I can make sure the pressure at the manifold is at 2.0 " wc. Once it arrives, I will post again to let you know if this fixes the problem. Hopefully, it will consistently fire up properly if the pressure is right.


 o
RE: Pentair Minimax NT E004

When you get Pentair on the phone and tell them your model number, there will probably be a pause, and a sigh.,from the tech. Don't let that bother you.
Seriously, that can be a hard heater to trouble shoot. Get help.


 o Post a Follow-Up

Please Note: Only registered members are able to post messages to this forum.

    If you are a member, please log in.

    If you aren't yet a member, join now!


Return to the Pools & Spas Forum

Information about Posting

  • You must be logged in to post a message. Once you are logged in, a posting window will appear at the bottom of the messages. If you are not a member, please register for an account.
  • Posting is a two-step process. Once you have composed your message, you will be taken to the preview page. You will then have a chance to review your post, make changes and upload photos.
  • After posting your message, you may need to refresh the forum page in order to see it.
  • Before posting copyrighted material, please read about Copyright and Fair Use.
  • We have a strict no-advertising policy!
  • If you would like to practice posting or uploading photos, please visit our Test forum.
  • If you need assistance, please Contact Us and we will be happy to help.


Learn more about in-text links on this page here