Return to the Pools & Spas Forum | Post a Follow-Up

 o
Installing the new Pentair Intellichlor IC-40

Posted by NickF (My Page) on
Tue, Aug 14, 12 at 19:36

my old one died after 4 yrs, so as I tried to install the new one, I finally realized that Pentair had changed the orientation of the flow through the cell "because hydraulics were causing the flow switch to activate even when water was not moving which would in return ruin the cell". If you try to install the new cell in the same orientation as the old one, your flow light will be RED.


Follow-Up Postings:

 o Post a Follow-Up

Please Note: Only registered members are able to post messages to this forum.

    If you are a member, please log in.

    If you aren't yet a member, join now!


Return to the Pools & Spas Forum

Information about Posting

  • You must be logged in to post a message. Once you are logged in, a posting window will appear at the bottom of the messages. If you are not a member, please register for an account.
  • Please review our Rules of Play before posting.
  • Posting is a two-step process. Once you have composed your message, you will be taken to the preview page. You will then have a chance to review your post, make changes and upload photos.
  • After posting your message, you may need to refresh the forum page in order to see it.
  • Before posting copyrighted material, please read about Copyright and Fair Use.
  • We have a strict no-advertising policy!
  • If you would like to practice posting or uploading photos, please visit our Test forum.
  • If you need assistance, please Contact Us and we will be happy to help.


Learn more about in-text links on this page here