Return to the Pools & Spas Forum | Post a Follow-Up

 o
Pool Plumbing

Posted by william77 (My Page) on
Wed, Jun 17, 09 at 22:08

We installed all of the 2.5"PVC pipe/plumbing and discovered that we had not used enough glue; hence, we discovered a number of leaks that we have since repaired/replaced the fittings/joints. The system is currently holding 60 psi of static air pressure. Do we have anything to worry about in the future? Should we tear out all of the pipe and replace all joints? If it is holding pressure currently will the system be safe to cover and proceed?


Follow-Up Postings:

 o
RE: Pool Plumbing

I am not a plumber but if it works now, thats all you need to worry about I would think


 o Post a Follow-Up

Please Note: Only registered members are able to post messages to this forum.

    If you are a member, please log in.

    If you aren't yet a member, join now!


Return to the Pools & Spas Forum

Information about Posting

  • You must be logged in to post a message. Once you are logged in, a posting window will appear at the bottom of the messages. If you are not a member, please register for an account.
  • Please review our Rules of Play before posting.
  • Posting is a two-step process. Once you have composed your message, you will be taken to the preview page. You will then have a chance to review your post, make changes and upload photos.
  • After posting your message, you may need to refresh the forum page in order to see it.
  • Before posting copyrighted material, please read about Copyright and Fair Use.
  • We have a strict no-advertising policy!
  • If you would like to practice posting or uploading photos, please visit our Test forum.
  • If you need assistance, please Contact Us and we will be happy to help.


Learn more about in-text links on this page here