Return to the Plumbing Forum | Post a Follow-Up

 o
Problems with Tankless Heater and Shower

Posted by jchang (My Page) on
Thu, Dec 27, 12 at 10:10

We recently installed a Rinnai tankless hot water heater in our new addition. The water leaves the heater, then travels to the master bath tub, out to a secondary bathroom, then back to the master sinks, the master shower and then back. We've installed a timer/pump based recirculation system. both the master and secondary showers are using thermostatic valves.

We've had nothing but problems with the shower since the system was finished. While the sinks and tubs get hot water after just a few seconds, the showers take anywhere from 15-90 seconds to get hot. We lose water pressure in the master shower when a sink is turned on. We get cold water slugs in the master shower. The thermostatic valves don't appear to regulate temperature properly, if at all. The pipes bang ferociously if we try to run both the master shower and bath.

The plumber our contractor uses thinks the valves need to be adjusted and/or the pipes need to be blown out, but after doing both, the problem doesn't seem to be fixed.

any ideas on what the problem(s) could be? We're at a complete loss.


Follow-Up Postings:

 o
RE: Problems with Tankless Heater and Shower

Could be that you have the tankless set too hot.

Thermostatic valves on the showers is the clue. They may moderate the hot water flow to a very low rate to maintain the shower within the target range. The tankless unit will shut off if the hot water flow rate falls too low, until the thermostatic valve ramps the hot flow up again, at which point the tankless unit fires up again, repeat, repeat, repeat. Thus, the cold water slugging you're experiencing.

Try dialing-back the tankless setpoint so that mostly hot water and very little cold flow is garnered at the showers. The tankless unit won't be cycling on/off at a higher hot water flow rate.

My house was built with an electric tankless unit 8 years ago. I have Moen thermostatic shower/tub valves and run them fully at the hot end of the range. I keep the tankless set at between 103F and 105F, and thus am (presumably) running 100% "hot" water flow at the shower. I've never had any issue with unsatisfactory shower temperature or cold-slugging.

I realize most people won't or can't run their hot water heater at such a low setting as I do ... but you can at least dial-back the setting to confirm if that solves the problem, and then decide how to proceed ... such as getting rid of the thermostatic valves, or finding a moderate tankless setting that works. Sounds like your tankless unit serves only the bathrooms in your new addition, not the kitchen and laundry area, so there's really no need to run it at a super-hot setting.

This post was edited by dadoes on Thu, Dec 27, 12 at 10:39


 o Post a Follow-Up

Please Note: Only registered members are able to post messages to this forum.

    If you are a member, please log in.

    If you aren't yet a member, join now!


Return to the Plumbing Forum

Information about Posting

  • You must be logged in to post a message. Once you are logged in, a posting window will appear at the bottom of the messages. If you are not a member, please register for an account.
  • Posting is a two-step process. Once you have composed your message, you will be taken to the preview page. You will then have a chance to review your post, make changes and upload photos.
  • After posting your message, you may need to refresh the forum page in order to see it.
  • Before posting copyrighted material, please read about Copyright and Fair Use.
  • We have a strict no-advertising policy!
  • If you would like to practice posting or uploading photos, please visit our Test forum.
  • If you need assistance, please Contact Us and we will be happy to help.


Learn more about in-text links on this page here