Return to the Plumbing Forum | Post a Follow-Up

 o
T&P relief valve

Posted by bibbus (My Page) on
Sun, Oct 14, 12 at 19:26

the flex line on my 50 gal GE Smart Water tank had a pin leak and I replaced it myself. I also drained the tank since it had been a long time. The water was clear when I first opened the valve at the bottom. I emptied a gallon or two before hooking up the garden hose and draining the entire heater. I refilled the tank and turned it back on and it seems to be working fine, except that when I test the t and p relief valve, it pours out water. I've tested it several times in the 24 hours since the repair. No air comes out - only high pressure water. What could be wrong?


Follow-Up Postings:

 o
RE: T&P relief valve

It SHOULD be water that comes out of the T&P. Your water heater does not have an air-charge.


 o Post a Follow-Up

Please Note: Only registered members are able to post messages to this forum.

    If you are a member, please log in.

    If you aren't yet a member, join now!


Return to the Plumbing Forum

Information about Posting

  • You must be logged in to post a message. Once you are logged in, a posting window will appear at the bottom of the messages. If you are not a member, please register for an account.
  • Posting is a two-step process. Once you have composed your message, you will be taken to the preview page. You will then have a chance to review your post, make changes and upload photos.
  • After posting your message, you may need to refresh the forum page in order to see it.
  • Before posting copyrighted material, please read about Copyright and Fair Use.
  • We have a strict no-advertising policy!
  • If you would like to practice posting or uploading photos, please visit our Test forum.
  • If you need assistance, please Contact Us and we will be happy to help.


Learn more about in-text links on this page here