Return to the Plumbing Forum | Post a Follow-Up

 o
plumbing smells

Posted by ed13 (My Page) on
Sun, Aug 21, 11 at 21:04

Just installed a new Toto toilet and now there is a sewer gas smell only when using the shower. Reinstalled toilet with new wax ring but no change. Ed


Follow-Up Postings:

 o
RE: plumbing smells

Did you install new floors?

Hard to diagnose. The problem is a trap seal: lavatory, shower, or toilet. Or..your wax ring is not sealing.

Alot of times when a flooring install is done, the flange is not set to the correct height, causing a very large gap to be filled with wax.

Is it a new shower insatll??

If it is just a toilet replacement and nothing else, that really narrows it down to the wax ring. Did you use a deep set seal? or possibly a jumbo wax ring? That may help.


 o Post a Follow-Up

Please Note: Only registered members are able to post messages to this forum.

    If you are a member, please log in.

    If you aren't yet a member, join now!


Return to the Plumbing Forum

Information about Posting

  • You must be logged in to post a message. Once you are logged in, a posting window will appear at the bottom of the messages. If you are not a member, please register for an account.
  • Please review our Rules of Play before posting.
  • Posting is a two-step process. Once you have composed your message, you will be taken to the preview page. You will then have a chance to review your post, make changes and upload photos.
  • After posting your message, you may need to refresh the forum page in order to see it.
  • Before posting copyrighted material, please read about Copyright and Fair Use.
  • We have a strict no-advertising policy!
  • If you would like to practice posting or uploading photos, please visit our Test forum.
  • If you need assistance, please Contact Us and we will be happy to help.


Learn more about in-text links on this page here