Return to the Plumbing Forum | Post a Follow-Up

 o
Water Softner ?

Posted by zeke1312 (My Page) on
Sun, Jun 27, 10 at 15:15

My Culligan softner keeps running water through it like it's stuck in part of the soft cycle. Any ideas?


Follow-Up Postings:

 o
RE: Water Softner ?

Either a seal or piston or motor problem.

Unplug the softener and put the softener in bypass or that water running to drain will add up on your water bill, You'll be using untreated water until you resolve this problem.

Most likely the softener needs to be rebuilt and if old the resin replaced. May cost more to repair than replace with a new industry standard softener that will be more efficient than what you have now.

What model and how old is the softener?

Has anyone been doing routine maintenance on the softener?

City water or well water?.


 o Post a Follow-Up

Please Note: Only registered members are able to post messages to this forum.

    If you are a member, please log in.

    If you aren't yet a member, join now!


Return to the Plumbing Forum

Information about Posting

  • You must be logged in to post a message. Once you are logged in, a posting window will appear at the bottom of the messages. If you are not a member, please register for an account.
  • Posting is a two-step process. Once you have composed your message, you will be taken to the preview page. You will then have a chance to review your post, make changes and upload photos.
  • After posting your message, you may need to refresh the forum page in order to see it.
  • Before posting copyrighted material, please read about Copyright and Fair Use.
  • We have a strict no-advertising policy!
  • If you would like to practice posting or uploading photos, please visit our Test forum.
  • If you need assistance, please Contact Us and we will be happy to help.


Learn more about in-text links on this page here