Return to the Plumbing Forum | Post a Follow-Up

 o
Stenner Pump Problem

Posted by centavo25 (My Page) on
Mon, Feb 11, 13 at 20:25

I have a Rain Soft system and the Stenner Pump does not seem to be drawing water from the chlorine tank. I have taking it apart and made sure there were no clogs but it still doens't seem to suck up the water. How do I know if the tube needs replacing or if it's a cam issue? The pump works fine I just don't know how to get it to draw up the chlorinated water.


Follow-Up Postings:

 o
RE: Stenner Pump Problem

HI, this is justin with Pentair Aquatic's, centavo25, your issue is the roller assembly is not expanding. you can pull the cover off and flip it up side down and do a counter clock wise turn. only while the cover is rotated clockwise as well, unlatched. after its expanded it should stay that way. it has to be expanded in order to suck water through it.

I hope this helps


 o Post a Follow-Up

Please Note: Only registered members are able to post messages to this forum.

    If you are a member, please log in.

    If you aren't yet a member, join now!


Return to the Plumbing Forum

Information about Posting

  • You must be logged in to post a message. Once you are logged in, a posting window will appear at the bottom of the messages. If you are not a member, please register for an account.
  • Please review our Rules of Play before posting.
  • Posting is a two-step process. Once you have composed your message, you will be taken to the preview page. You will then have a chance to review your post, make changes and upload photos.
  • After posting your message, you may need to refresh the forum page in order to see it.
  • Before posting copyrighted material, please read about Copyright and Fair Use.
  • We have a strict no-advertising policy!
  • If you would like to practice posting or uploading photos, please visit our Test forum.
  • If you need assistance, please Contact Us and we will be happy to help.


Learn more about in-text links on this page here