Return to the Plumbing Forum | Post a Follow-Up

 o
Water Heater not heating

Posted by tim45z10 (My Page) on
Tue, Feb 8, 11 at 11:43

I have a whirlpool heater. It has had the upgrade kit installed. Sometimes the heater will not heat when the water temp. drops. It is not the thermocouple, because the pilot is still lit. What should I look for or test? Thank you for your help.


Follow-Up Postings:

 o
RE: Water Heater not heating

Water temperature sensor.
Water temperature switch.
The "brains" of the control unit could be fried.


 o Post a Follow-Up

Please Note: Only registered members are able to post messages to this forum.

    If you are a member, please log in.

    If you aren't yet a member, join now!


Return to the Plumbing Forum

Information about Posting

  • You must be logged in to post a message. Once you are logged in, a posting window will appear at the bottom of the messages. If you are not a member, please register for an account.
  • Posting is a two-step process. Once you have composed your message, you will be taken to the preview page. You will then have a chance to review your post, make changes and upload photos.
  • After posting your message, you may need to refresh the forum page in order to see it.
  • Before posting copyrighted material, please read about Copyright and Fair Use.
  • We have a strict no-advertising policy!
  • If you would like to practice posting or uploading photos, please visit our Test forum.
  • If you need assistance, please Contact Us and we will be happy to help.


Learn more about in-text links on this page here