Return to the Photography Forum | Post a Follow-Up

 o
could it be the batteries??

Posted by cream_please (My Page) on
Thu, Aug 2, 07 at 20:08

As a digital amateur, I need your help in understanding why my photos did not download. The usb cable was plugged in, the camera turned on, the green light was blinking, but no pictures transferred.
Could it have been the batteries are low?
Do they play a part in the downloading process?
Thanks,
cream


Follow-Up Postings:

 o
RE: could it be the batteries??

It's sure possible. I think it sucks a lot of juice out of the camera. Can you recharge the batteries and try again?
JoanMN


 o
RE: could it be the batteries??

Thanks, Joan
I went ahead and got some rechargeable batteries and a charger.
Cream


 o
RE: could it be the batteries??

It could be the batteries but sometimes mine does that and I just turn off the camera and try again and they usually download the second try.


 o Post a Follow-Up

Please Note: Only registered members are able to post messages to this forum.

    If you are a member, please log in.

    If you aren't yet a member, join now!


Return to the Photography Forum

Information about Posting

  • You must be logged in to post a message. Once you are logged in, a posting window will appear at the bottom of the messages. If you are not a member, please register for an account.
  • Posting is a two-step process. Once you have composed your message, you will be taken to the preview page. You will then have a chance to review your post, make changes and upload photos.
  • After posting your message, you may need to refresh the forum page in order to see it.
  • Before posting copyrighted material, please read about Copyright and Fair Use.
  • We have a strict no-advertising policy!
  • If you would like to practice posting or uploading photos, please visit our Test forum.
  • If you need assistance, please Contact Us and we will be happy to help.


Learn more about in-text links on this page here