Return to the Paint Forum | Post a Follow-Up

 o
What happened to my paint project

Posted by gwenbob (My Page) on
Sun, Jul 22, 12 at 21:28

I'm using Rustoleum spray products to give my bathroom medicine cabinet a new look. It was solid Oak and I wanted a non grainy look so I used the Zinsser cover stain primer to start. Called the support number before I started and got some tips also confirmed I could use the 2x color after. After a good drying period I proceeded to use the Rustoleum 2x color that was satin finish. Weather conditions were within the cans directions. Did 3 coats looked good until it dried 48 hours and I saw a blotchy finish. Blotches of dull and then blotches of shiny satin finish. So today after the 48 hours of dry time you can re coat again. I did and it got worse. Today it was a little more humid but within the cans directions. 40 percent humidity the first spray time and 50 percent the second time.

What happened?? It looked great nice even wet look and then it dried ugly. Now much worse then before. Very dull patches with some shiny blotchy patches. I did proper can shaking too. Not a real big project.
How can I fix this what did I do wrong.

Thanks for your thoughts


Follow-Up Postings:

 o
RE: What happened to my paint project

Maybe too many coats in the given time.
Best advice is to let everything cure to a hard dry state, and apply one final coat in perfect conditions. Not too hot and no humidity.
Casey


 o
RE: What happened to my paint project

I'd agree it was probably from doing too many coats too soon and spraying unevenly. You may have been sweeping the can from side to side which tends to give uneven coverage, but you'll get a more even coat if you move the can from side to side in a straight line by keeping your hand the same distance from the object as you move it back and forth. It's also best to build up the layers gradually with lighter coats until you get full coverage.


 o Post a Follow-Up

Please Note: Only registered members are able to post messages to this forum.

    If you are a member, please log in.

    If you aren't yet a member, join now!


Return to the Paint Forum

Information about Posting

  • You must be logged in to post a message. Once you are logged in, a posting window will appear at the bottom of the messages. If you are not a member, please register for an account.
  • Posting is a two-step process. Once you have composed your message, you will be taken to the preview page. You will then have a chance to review your post, make changes and upload photos.
  • After posting your message, you may need to refresh the forum page in order to see it.
  • Before posting copyrighted material, please read about Copyright and Fair Use.
  • We have a strict no-advertising policy!
  • If you would like to practice posting or uploading photos, please visit our Test forum.
  • If you need assistance, please Contact Us and we will be happy to help.


Learn more about in-text links on this page here