Return to the Laundry Room Forum | Post a Follow-Up

 o
samsung dv210

Posted by inferno493 (My Page) on
Tue, Sep 10, 13 at 0:31

In a fit of inattentiveness I hooked up my dryer cord incorrectly, connecting the ground to the wrong terminal block. After I hooked it up the display came to life and I smelled ozone, the display then went dark. After correcting the error, the display is still not working. Any ideas on what I am going to need to replace?


Follow-Up Postings:

 o
RE: samsung dv210

It's hard to say with limited information.


 o Post a Follow-Up

Please Note: Only registered members are able to post messages to this forum.

    If you are a member, please log in.

    If you aren't yet a member, join now!


Return to the Laundry Room Forum

Information about Posting

  • You must be logged in to post a message. Once you are logged in, a posting window will appear at the bottom of the messages. If you are not a member, please register for an account.
  • Please review our Rules of Play before posting.
  • Posting is a two-step process. Once you have composed your message, you will be taken to the preview page. You will then have a chance to review your post, make changes and upload photos.
  • After posting your message, you may need to refresh the forum page in order to see it.
  • Before posting copyrighted material, please read about Copyright and Fair Use.
  • We have a strict no-advertising policy!
  • If you would like to practice posting or uploading photos, please visit our Test forum.
  • If you need assistance, please Contact Us and we will be happy to help.


Learn more about in-text links on this page here