Return to the Laundry Room Forum | Post a Follow-Up

 o
Can I fix this?

Posted by rogerv (My Page) on
Sat, Jul 20, 13 at 21:10

I have a Kenmore front loading washing machine that's about 12-years old (417.41142000). The fabric softener part of the dispenser drawer has been having problems being drained by the end of the wash, I was finding it full a lot. It looked like it had been filled with water, but the water had not drained. So I cleaned out the inside of the dispenser drawer compartment with a water/bleach solution since I could see mold/mildew in there, and made sure that the little drawer insert for the fabric softener could itself drain.

After that, I was still seeing the same thing, that the fabric softener part of the dispenser drawer wasn't empty when the wash was done, so I decided to try using vinegar instead of fabric softener to see if that wouldn't clean things out.

So what I'm seeing now when the wash is done is that the same original vinegar that was there seems to be still there in the fabric softener partition. As though there were no water going in there to wash it out in the first place. It doesn't look like it just failed to drain, still about the same level (about half full) and smells like vinegar.

Any ideas on what might be wrong here? I will most likely pay someone else to fix it if doing that entails taking the machine apart...And I'm also asking myself if I'll get enough life out of a 12-year old washer to justify a $200 repair bill.


Follow-Up Postings:

 o
RE: Can I fix this?

Per the parts diagram, this model uses a valve assembly on the dispenser housing to divert the water flow into the proper cup. Two solenoids on the assembly. Presumably you have cups for detergent, bleach, and softener. Presumably water flows through only the detergent cup when neither of the valves is engaged. One is for bleach, the other for softener.

Run a cycle with the drawer removed, and watch during fills if the water flow does or does not aim for the proper cup at the proper times. If not, could be a bad valve.

I find the valve assembly priced at $40 at a particular online source (there are several choices). The entire dispenser housing including valves is $52.


 o
RE: Can I fix this?

Hmmm...worth a try. I'll need to see in which cycle the fabric softener is supposed to be dispensed. That might well be in the owner's manual.

Could this be a clog somewhere in the water line, do you think, as well as a valve? Hate to replace the valves and have it still be not working right *smile*.

Thanks, this was very helpful.


 o
RE: Can I fix this?

Softener should dispense into the final rinse. If the machine has a 2nd or extra rinse option, then softener should still go into the final rinse if the machine is "smart" enough to make that adjustment.

Detergent of course goes into the wash.

Bleach usually releases into the first rinse, or possibly toward end of the wash period depending on the machine's design/programming.

The water flow may not necessarily divert fully into the bleach and softener cups ... part of it may go to bleach or softener and part to the detergent cup ... but there should be at least some of the flow go into bleach or softener at the appropriate time.


 o
RE: Can I fix this?

Thanks for the update, I'll be trying this out as soon as I get a chance. Makes a lot of sense, particularly since the dispenser drawer has no interlock.


 o Post a Follow-Up

Please Note: Only registered members are able to post messages to this forum.

    If you are a member, please log in.

    If you aren't yet a member, join now!


Return to the Laundry Room Forum

Information about Posting

  • You must be logged in to post a message. Once you are logged in, a posting window will appear at the bottom of the messages. If you are not a member, please register for an account.
  • Please review our Rules of Play before posting.
  • Posting is a two-step process. Once you have composed your message, you will be taken to the preview page. You will then have a chance to review your post, make changes and upload photos.
  • After posting your message, you may need to refresh the forum page in order to see it.
  • Before posting copyrighted material, please read about Copyright and Fair Use.
  • We have a strict no-advertising policy!
  • If you would like to practice posting or uploading photos, please visit our Test forum.
  • If you need assistance, please Contact Us and we will be happy to help.


Learn more about in-text links on this page here