Return to the Laundry Room Forum | Post a Follow-Up

 o
Samsung FL 520 repair didn't work...

Posted by dave1812 (My Page) on
Thu, May 10, 12 at 20:49

Yesterday I tried to get Pure Cycle to complete, three times. No joy. With 23 minutes left, it stops with an error message about there being a water supply problem (something that doesn't occur on any other cycle). this happened about a month ago, and prior to that, Pure Cycle ran numerous times without incident.

Samsung told the local techs to install two components--one was the control head, and the other I don't know what it's called other than "board". I ran Pure Cycle after the tech left. Same problem! At 23 minutes to go, it stops with the error about the water supply.

I haven't seen this complaint on line.

anyone ever heard of this and if so, do you know what the fix is?

I've already spoken with the local repair people and they have ordered something else.

oh, and the two parts installed today were also supposed to fix my complaint about there being no hot water in the Normal Cycle. that remains unfixed--water temp during wash is always 79 degrees from start of wash until the rinse starts. "cold" rinse temp is barely cooler! LOL! It's 72 degrees. gotta love the ATC.


Follow-Up Postings:

 o
RE: Samsung FL 520 repair didn't work...

Local repair shop called me late yesterday with the info that they have ordered another part...we'll see if the third part is the charm.


 o
RE: Samsung FL 520 repair didn't work...

No advice, I'm afraid but I really hate learning of your troubles with this machine. I have been interested in Samsung for a number of reasons. Pretty good reports on various review sites from other owners/users. This is discouraging.


 o
RE: Samsung FL 520 repair didn't work...

yes, the fact that two modules were replaced and the Normal Hot feature doesn't work, and the "Water Supply Problem" error during Pure Cycle is still an issue, makes me wonder what inside the washer is failing. I can live with no hot water in Normal wash, but I've got to have the Pure Cycle complete the entire cycle or soap residue remains. Even after four aborted Pure Cycles were run in one day, there were still suds showing. When Pure Cycle runs properly, at the end of the cycle the water is pristine and the washer smells showroom fresh (ie, it has zero soap smell).


 o Post a Follow-Up

Please Note: Only registered members are able to post messages to this forum.

    If you are a member, please log in.

    If you aren't yet a member, join now!


Return to the Laundry Room Forum

Information about Posting

  • You must be logged in to post a message. Once you are logged in, a posting window will appear at the bottom of the messages. If you are not a member, please register for an account.
  • Posting is a two-step process. Once you have composed your message, you will be taken to the preview page. You will then have a chance to review your post, make changes and upload photos.
  • After posting your message, you may need to refresh the forum page in order to see it.
  • Before posting copyrighted material, please read about Copyright and Fair Use.
  • We have a strict no-advertising policy!
  • If you would like to practice posting or uploading photos, please visit our Test forum.
  • If you need assistance, please Contact Us and we will be happy to help.


Learn more about in-text links on this page here