Return to the Laundry Room Forum | Post a Follow-Up

 o
F&P Smart Drive, PRIDE 5.5

Posted by Patric (My Page) on
Sat, Feb 22, 14 at 19:14

The above was given to us by a family member and had been sitting in storage for sometime. We were faced with the reality that the machine could have seized up or it was going to function as it should without any surprises. Sadly the latter has confirmed our suspicions.

While the machine cycle started as it should have, it was when it reached the RINSE mode that the length of silence numbed us. Not even an engagement sound - lights still blazing but no action or warning sign.

I would assume that if it were a pump problem the automated system would click over and the pump would signal its refusal to engage like some sort of gearing. But it was just quiet as. We advanced it to the second orange light in the cycle and the agitator started to wash again for about 1 minute and then silence. At this point we powered down and left the machine for about 20 minutes and tried again but no luck...could it be that the automated system needs resetting or could it be that the pump has simply died.

If there is someone who might be able to assist in anyway who may have experienced the same problem and would like to share their solution that might allow us to preserve this dinosaur, please help. In anticipation thank you so much - appreciated. Patrick (patric)


Follow-Up Postings:

 o
RE: F&P Smart Drive, PRIDE 5.5

What is the specific model number of your machine? Pride is a marketing line designation, not so much a model numbering.

That being said, the first action upon reaching rinse should be to drain the wash water. A dead pump would prevent it from doing so. Look under the machine at the pump for visual evidence of failure ... such as rusting/mineral deposits from leaking, try turning it by hand via the cooling fan to check if it's seized ... you may be able to break it loose enough to run, although it probably should be replaced if so.


 o
RE: F&P Smart Drive, PRIDE 5.5

thank you for your response. Yes I did manage to free up the fan which incidently had seized, was extremely tight however there is now no power - dead. It appears that due to the times spent re-testing, the seized pump was drawing to much current that has now caused the controller to fail. So we have decided to replace it with another.

Thank you though for your help and advise..much appreciated.


 o Post a Follow-Up

Please Note: Only registered members are able to post messages to this forum.

    If you are a member, please log in.

    If you aren't yet a member, join now!


Return to the Laundry Room Forum

Information about Posting

  • You must be logged in to post a message. Once you are logged in, a posting window will appear at the bottom of the messages. If you are not a member, please register for an account.
  • Posting is a two-step process. Once you have composed your message, you will be taken to the preview page. You will then have a chance to review your post, make changes and upload photos.
  • After posting your message, you may need to refresh the forum page in order to see it.
  • Before posting copyrighted material, please read about Copyright and Fair Use.
  • We have a strict no-advertising policy!
  • If you would like to practice posting or uploading photos, please visit our Test forum.
  • If you need assistance, please Contact Us and we will be happy to help.


Learn more about in-text links on this page here