Return to the Heating & Air Conditioning Forum | Post a Follow-Up

 o
Gas Furnace - Burning smell at return

Posted by blakemcginnis (My Page) on
Tue, Nov 27, 07 at 13:19

Hi guys, I've got a problem and was hoping someone might have an idea as to what's going on.

Two days ago, it was the first really cold day here and so we had the heater running most of the day. It short cycles, I noticed it runs about 3 minutes, then goes off for 3 minutes, etc. Well, later that night I started smelling a burning smell (like an electrical/ozone type smell) and finally tracked it down to the stairway leading upstairs, where there is a hinged grill with a filter in it, for the return air and the thermostat is a few feet away at the top of the stairs. I panicked and went all through the house looking at any electronics/appliances, went outside to look for smoke, went under the house in the crawlspace to sniff around the furnace, but it seemed to just be localized right around that return air vent area. I went to all the other vents and no smell, just at the fresh air return!

I turned the furnace off for a minute and then tried to turn it back on, even setting it very high, at about 78 and it wouldn't come on. So I turned it off for the night and finally went to bed. The next morning, my wife ran the heat for about 30 minutes before she went to work and it ran fine, no smell.

I came home yesterday with a few ideas to check. I went to the crawl space and opened up the door where the blower is located to see if there was a filter in there that I didn't know about (I've only ever changed the filter upstairs in the return air grill). But I didn't see any filters. The furnace is a 15-20 yr old horizontal Rheem unit, by the way. The Blower motor was very dusty, so I vacuumed it off as best I could (couldn't get to the coil inside the motor) and closed it up. I ran the heater for about 2 hours or so no problem. Then, I started to smell the burning smell again, and went back to the stairway and the return vent, and the burning smell was back, so I shut off the furnace. I was thinking maybe the blower was overheating or something, so I tried just setting the thermostat to 'Fan On', but the fan wouldn't come on. In the morning, tried the 'Fan On' setting and it came right on, ran the heat for 30 minutes before leaving for work, no problem.

Any ideas? I haven't had a HVAC person come to check it out yet, but I've talked to a few that I knew and they were all baffled as to why the smell would be at the return grill and not at the vents.

For the sake of completeness, I will try to list any other issues with the furnace that I've had in the last couple of weeks.

- Had trouble lighting the pilot light at the beginning of the season, so I replaced thermocouple and cleaned the pilot.

- Noticed that if I kept the burner cover aluminum plate on, the pilot light would waver on and off of the thermocouple and eventually go out after 30 mins or an hour, so I had to leave the plate off.

- Removed rust flakes/scale that had fallen on top of the burners several different times.

- Also noticed that there is a black wire that is not connected on the terminal/relay thing down by the furnace. It is not screwed down, it is just resting on one of the screws.

Thanks in advance for any advice you guys might have.


Follow-Up Postings:

 o
RE: Gas Furnace - Burning smell at return

Any "loose air" in the house is going to be attracted to the return ... even if it's coming from a burned piece of turkey in the toaster oven. Is there more than the one return, which smells?

I don't think the heat cycle should be that short.

I'd look into the fan, which is on the other end of the "return".


 o
RE: Gas Furnace - Burning smell at return

Just the one return. I had an HVAC guy come out yesterday afternoon and he switched out the thermostat and that stopped the short-cycling. Like you, he also thinks it could be the blower motor.


 o Post a Follow-Up

Please Note: Only registered members are able to post messages to this forum.

    If you are a member, please log in.

    If you aren't yet a member, join now!


Return to the Heating & Air Conditioning Forum

Information about Posting

  • You must be logged in to post a message. Once you are logged in, a posting window will appear at the bottom of the messages. If you are not a member, please register for an account.
  • Posting is a two-step process. Once you have composed your message, you will be taken to the preview page. You will then have a chance to review your post, make changes and upload photos.
  • After posting your message, you may need to refresh the forum page in order to see it.
  • Before posting copyrighted material, please read about Copyright and Fair Use.
  • We have a strict no-advertising policy!
  • If you would like to practice posting or uploading photos, please visit our Test forum.
  • If you need assistance, please Contact Us and we will be happy to help.


Learn more about in-text links on this page here