Return to the Heating & Air Conditioning Forum | Post a Follow-Up

 o
Help needed on igniting Bryant Heating System

Posted by indyboy6944 (My Page) on
Wed, Nov 16, 11 at 11:48

Dear All,

I have a Bryant Cooling/Heating System.

From yesterday, the heating began to stop working with all cold air blown into my house vents. It did work well 2 days ago. After checking, there is no fire on the furnace and a LED red light under it now blinks.

Could ignition fire hole be blocked with dirt or something else happened? Thanks


Follow-Up Postings:

 o
RE: Help needed on igniting Bryant Heating System

could be Debris or another fault I would call a pro for gas heat can be dangerous.


 o Post a Follow-Up

Please Note: Only registered members are able to post messages to this forum.

    If you are a member, please log in.

    If you aren't yet a member, join now!


Return to the Heating & Air Conditioning Forum

Information about Posting

  • You must be logged in to post a message. Once you are logged in, a posting window will appear at the bottom of the messages. If you are not a member, please register for an account.
  • Posting is a two-step process. Once you have composed your message, you will be taken to the preview page. You will then have a chance to review your post, make changes and upload photos.
  • After posting your message, you may need to refresh the forum page in order to see it.
  • Before posting copyrighted material, please read about Copyright and Fair Use.
  • We have a strict no-advertising policy!
  • If you would like to practice posting or uploading photos, please visit our Test forum.
  • If you need assistance, please Contact Us and we will be happy to help.


Learn more about in-text links on this page here