Return to the Heating & Air Conditioning Forum | Post a Follow-Up

 o
warm(ambient temperature) suction line

Posted by jaywalker1981 (My Page) on
Thu, Aug 14, 14 at 22:54

My HVAC stopped working all of a sudden. Its an R-22 System. The Suction line is warm(ambient temperature) and the liquid line is at the same temperature. The Low side as well as the high side pressure with the compressor off is about 150 psi(manufactured recommended Lo Side Pressure is 150 PSI as well). The compressor draws about 18 amps when the call for heat is made.

On turning the compressor on, the suction side pressure quickly drops to 0 and the liquid side pressure goes up to 180 from 150.
What could be the problem?

This post was edited by jaywalker1981 on Fri, Aug 15, 14 at 2:46


Follow-Up Postings:

 o
RE: warm(ambient temperature) suction line

It sounds like the expansion valve is not working.


 o Post a Follow-Up

Please Note: Only registered members are able to post messages to this forum.

    If you are a member, please log in.

    If you aren't yet a member, join now!


Return to the Heating & Air Conditioning Forum

Information about Posting

  • You must be logged in to post a message. Once you are logged in, a posting window will appear at the bottom of the messages. If you are not a member, please register for an account.
  • Posting is a two-step process. Once you have composed your message, you will be taken to the preview page. You will then have a chance to review your post, make changes and upload photos.
  • After posting your message, you may need to refresh the forum page in order to see it.
  • Before posting copyrighted material, please read about Copyright and Fair Use.
  • We have a strict no-advertising policy!
  • If you would like to practice posting or uploading photos, please visit our Test forum.
  • If you need assistance, please Contact Us and we will be happy to help.


Learn more about in-text links on this page here