Return to the Heating & Air Conditioning Forum | Post a Follow-Up

 o
Carrier Split system not cooling good

Posted by larrylwill (My Page) on
Wed, May 25, 11 at 21:55

I have a carrier 2 stage variable speed blower 4 ton heat pump, its 10 years old and the warentee just ran out. Last year they had to solder a small tube in the compressor housing. The year before they had to replace a relay, also last year the 2x4 that was holding the condenser off the ground broke due to rot.
Yesterday I noticed it wasn't cooling good and I measured the in temp vrs the out temp and it was running 5-7 degrees. I called the company and they put a gauge on and added some freon and said the Expansion valve is bad. $800 to replace. After he left I took a look and saw the tubes to it were frosted up and some of the A coil tubes at the ends were frosted up. I beat on the valve a bit and after letting it thaw overnight I am getting 10-12 degree temp diff but the thing has not shut off since I turned it on it, just keeps even at 80 degrees inside, outside it was 90. Right now its 79 outside and 78 inside and has been running full boar since 3pm when I turned it on. Normally it would run for 10-15 minuets and shut off throughout the day.

Is this typically what happens if the TXV goes bad?

I found another company that will replace it for $400, since the system is 10 years old I am looking at new ones. The best bang for the buck seems to be a Goodman 14 seer with duel stage compressor and variable speed at $3200 shipped. Goodman seems to be in the middle of the pack as to complaints.

any comments on new Goodman heat pumps


Follow-Up Postings:

 o
RE: Carrier Split system not cooling good

a 2 x 4 as a condenser pad? what kind of nonsense is that.

post mdl nember of outside condenser and inside air handler.

just from a distance, I think you need another opinion from an HVAC pro-preferably a Carrier dealer before I would give up on your system.

IMO


 o Post a Follow-Up

Please Note: Only registered members are able to post messages to this forum.

    If you are a member, please log in.

    If you aren't yet a member, join now!


Return to the Heating & Air Conditioning Forum

Information about Posting

  • You must be logged in to post a message. Once you are logged in, a posting window will appear at the bottom of the messages. If you are not a member, please register for an account.
  • Please review our Rules of Play before posting.
  • Posting is a two-step process. Once you have composed your message, you will be taken to the preview page. You will then have a chance to review your post, make changes and upload photos.
  • After posting your message, you may need to refresh the forum page in order to see it.
  • Before posting copyrighted material, please read about Copyright and Fair Use.
  • We have a strict no-advertising policy!
  • If you would like to practice posting or uploading photos, please visit our Test forum.
  • If you need assistance, please Contact Us and we will be happy to help.


Learn more about in-text links on this page here