Return to the Home Entertainment Forum | Post a Follow-Up

 o
blower delay way to long

Posted by micro368 (My Page) on
Thu, Dec 26, 13 at 9:16

I purchased this home in august this is my first ever experience being around a heat pump. The outside unit was dead when I purchased the home. It was replaced with a Payne condenser unit. (4 ton) The air handler is a goodman (ar48-1). The issue I am having is that outside unit will come but the air handler will take over 10 mins to engage. Well by that time the temperature has dropped 2-3 degrees. Then once the fan engages it will run to try meet the set point. When its in the upper 20's this will cause the aux to engage.
I can tell the blower relay has been replaced at one time. What can I do to fix this issue. It is running so inefficient to me.


Follow-Up Postings:

 o
RE: blower delay way to long

Hvac forum


 o Post a Follow-Up

Please Note: Only registered members are able to post messages to this forum.

    If you are a member, please log in.

    If you aren't yet a member, join now!


Return to the Home Entertainment Forum

Information about Posting

  • You must be logged in to post a message. Once you are logged in, a posting window will appear at the bottom of the messages. If you are not a member, please register for an account.
  • Posting is a two-step process. Once you have composed your message, you will be taken to the preview page. You will then have a chance to review your post, make changes and upload photos.
  • After posting your message, you may need to refresh the forum page in order to see it.
  • Before posting copyrighted material, please read about Copyright and Fair Use.
  • We have a strict no-advertising policy!
  • If you would like to practice posting or uploading photos, please visit our Test forum.
  • If you need assistance, please Contact Us and we will be happy to help.


Learn more about in-text links on this page here