Return to the Garages/Workshops Forum | Post a Follow-Up

 o
1/2 HP craftsman garage door opener

Posted by topdesertdawg (My Page) on
Sat, Dec 1, 07 at 19:06

I own a 1/2 HP craftsman garage door opener, 75th anniversary version and the sensor continues to blink on one of the door opener units from the wall unit and both doors continue to stick in cold weather. I have used WD-40 and other lubricants to no avail. What is my next course of action?


Follow-Up Postings:

 o
RE: 1/2 HP craftsman garage door opener

I don't know what you are lubricating or what kind of door you have but if you are lubricating the rails of a sectional door you should quit and clean up all the stuff. This could be the cause of your problem. If this doesn't help you really need to call a door technician.


 o Post a Follow-Up

Please Note: Only registered members are able to post messages to this forum.

    If you are a member, please log in.

    If you aren't yet a member, join now!


Return to the Garages/Workshops Forum

Information about Posting

  • You must be logged in to post a message. Once you are logged in, a posting window will appear at the bottom of the messages. If you are not a member, please register for an account.
  • Please review our Rules of Play before posting.
  • Posting is a two-step process. Once you have composed your message, you will be taken to the preview page. You will then have a chance to review your post, make changes and upload photos.
  • After posting your message, you may need to refresh the forum page in order to see it.
  • Before posting copyrighted material, please read about Copyright and Fair Use.
  • We have a strict no-advertising policy!
  • If you would like to practice posting or uploading photos, please visit our Test forum.
  • If you need assistance, please Contact Us and we will be happy to help.


Learn more about in-text links on this page here