Return to the Garages/Workshops Forum | Post a Follow-Up

 o
Craftsman GDO problem

Posted by dickens (My Page) on
Tue, Oct 16, 07 at 10:12

We have a Craftsman 1/2HP 139.53900 GDO that opens fine but when closing it goes down a couple inches, reverses then the light flashes. The door can be closed by holding the button down from inside the garage. The sensors are in perfect alignment. Another symptom is that some times the GDO light will come on for the 4 1/2 minutes then go off all by itself. It does this at all times of the day and night. The green light on back of the unit also blinks 5 times intermittently. I read somewhere that this might be caused by a bad RPM sesor. Could this be the problem or is it possibly a bad sensor, control circuit board or something completely different. The unit is 6 years old and I hate to replace the opener unit unless absolutely necessary.
Possibly more information: The sensors are in perfect alignment. The sending and receiving units' lights are lit solid. I even checked to make sure the wires were not shorted in some way. The blinking light on the back of the unit, and the GDO light going on and off by itself lead me to believe the problem is in the RPM sensor. My main concern is could there be a problem with one of the sensor units themselves (i.e. the receiving unit), or possibly a problem with the control circuit board. I hate to replace a lot of expensive parts and still not solve the problem. Thanks in advance for your help.


Follow-Up Postings:

 o
RE: Craftsman GDO problem

I have this same problem as Dickens with the door opening a couple of inches and then the light flashes and if you use the mounted opener in the garage by holding it down until the door closes, it will close, but the remote in the car will not close it


 o
RE: Craftsman GDO problem

kurt-shortstop, which is it your door won't open or won't close?


 o Post a Follow-Up

Please Note: Only registered members are able to post messages to this forum.

    If you are a member, please log in.

    If you aren't yet a member, join now!


Return to the Garages/Workshops Forum

Information about Posting

  • You must be logged in to post a message. Once you are logged in, a posting window will appear at the bottom of the messages. If you are not a member, please register for an account.
  • Please review our Rules of Play before posting.
  • Posting is a two-step process. Once you have composed your message, you will be taken to the preview page. You will then have a chance to review your post, make changes and upload photos.
  • After posting your message, you may need to refresh the forum page in order to see it.
  • Before posting copyrighted material, please read about Copyright and Fair Use.
  • We have a strict no-advertising policy!
  • If you would like to practice posting or uploading photos, please visit our Test forum.
  • If you need assistance, please Contact Us and we will be happy to help.


Learn more about in-text links on this page here