Return to the Garages/Workshops Forum | Post a Follow-Up

 o
Generac 7000 Generator not producing power

Posted by davidinbloodvein (My Page) on
Sun, Aug 19, 07 at 14:58

I have a generac 7000 which suddenly produces no power. The idle control does not seem to be working as well. Ordinarily the generator only idles up when the power is being used. Now it neither generates power or idles down. It seems that the problem I'm having affects both the idle control and its ability to generate power. On the 120 volt side it only produces 4 volts and on the 240 volt side it only produces 8 volts. Can anyone help me on this?


Follow-Up Postings:

 o Post a Follow-Up

Please Note: Only registered members are able to post messages to this forum.

    If you are a member, please log in.

    If you aren't yet a member, join now!


Return to the Garages/Workshops Forum

Information about Posting

  • You must be logged in to post a message. Once you are logged in, a posting window will appear at the bottom of the messages. If you are not a member, please register for an account.
  • Posting is a two-step process. Once you have composed your message, you will be taken to the preview page. You will then have a chance to review your post, make changes and upload photos.
  • After posting your message, you may need to refresh the forum page in order to see it.
  • Before posting copyrighted material, please read about Copyright and Fair Use.
  • We have a strict no-advertising policy!
  • If you would like to practice posting or uploading photos, please visit our Test forum.
  • If you need assistance, please Contact Us and we will be happy to help.


Learn more about in-text links on this page here