Return to the Garages/Workshops Forum | Post a Follow-Up

 o
Craftsman 1/2 HP garage door

Posted by Dont88 (My Page) on
Sun, Aug 7, 11 at 13:11

I've a 5-year old Craftsman 1/2 HP garage door which worked well until we recently came back from a 10-day vocation. The remote controls and wall panel stoped working. When I pressed the remote, all I heard was clicking noise from the main unit. I've read a lot of messages in this forum and am wondering if this is a 'logic board' problem. Any input is appreciated. Thanks


Follow-Up Postings:

 o
RE: Craftsman 1/2 HP garage door

Is your door stuck in the open position?


 o
RE: Craftsman 1/2 HP garage door

Hi don

I'm not 100% sure, but I don't think the door is 'stuck' in any way. It just won't open (in respond to remote control). I now use the door manually. Thanks for your input.


 o Post a Follow-Up

Please Note: Only registered members are able to post messages to this forum.

    If you are a member, please log in.

    If you aren't yet a member, join now!


Return to the Garages/Workshops Forum

Information about Posting

  • You must be logged in to post a message. Once you are logged in, a posting window will appear at the bottom of the messages. If you are not a member, please register for an account.
  • Posting is a two-step process. Once you have composed your message, you will be taken to the preview page. You will then have a chance to review your post, make changes and upload photos.
  • After posting your message, you may need to refresh the forum page in order to see it.
  • Before posting copyrighted material, please read about Copyright and Fair Use.
  • We have a strict no-advertising policy!
  • If you would like to practice posting or uploading photos, please visit our Test forum.
  • If you need assistance, please Contact Us and we will be happy to help.


Learn more about in-text links on this page here