Return to the Garages/Workshops Forum | Post a Follow-Up

 o
Craftsman Garage Door Opener light problem

Posted by mhaarhues (My Page) on
Mon, Jul 30, 07 at 15:56

We have a Craftsman garage door opener that has been working fine. Yesterday, the overhead lights quit working when you open or close the door or walk in front of the sensors. We checked the bulbs and replaced one which was burned out. The lights still do not work...for no apparent reason. Has anyone experienced this before and how do you fix it?


Follow-Up Postings:

 o
RE: Craftsman Garage Door Opener light problem

There is a relay and supporting circuitry that controls those lights. It sounds like one has quit working. Have you had lightning recently. This is a frequent cause of this problem. Unfortunately the fix is a new logic board which is expensive.


 o Post a Follow-Up

Please Note: Only registered members are able to post messages to this forum.

    If you are a member, please log in.

    If you aren't yet a member, join now!


Return to the Garages/Workshops Forum

Information about Posting

  • You must be logged in to post a message. Once you are logged in, a posting window will appear at the bottom of the messages. If you are not a member, please register for an account.
  • Please review our Rules of Play before posting.
  • Posting is a two-step process. Once you have composed your message, you will be taken to the preview page. You will then have a chance to review your post, make changes and upload photos.
  • After posting your message, you may need to refresh the forum page in order to see it.
  • Before posting copyrighted material, please read about Copyright and Fair Use.
  • We have a strict no-advertising policy!
  • If you would like to practice posting or uploading photos, please visit our Test forum.
  • If you need assistance, please Contact Us and we will be happy to help.


Learn more about in-text links on this page here