Return to the Garages/Workshops Forum | Post a Follow-Up

 o
Echo SRM 1501 Trimmer will not stay running

Posted by jwm66ss (My Page) on
Tue, Jun 29, 10 at 7:47

I have cleaned the carb.Gas and oil mixture is fresh.The spark plug is good.Muffler screen has been cleaned.The trimmer will start and run when I pour fuel directly into the carb.Then it stops when that fuel is burned out.Does this sound like a diaphragm problem or possibly a small amount of trash still in the carb.?


Follow-Up Postings:

 o Post a Follow-Up

Please Note: Only registered members are able to post messages to this forum.

    If you are a member, please log in.

    If you aren't yet a member, join now!


Return to the Garages/Workshops Forum

Information about Posting

  • You must be logged in to post a message. Once you are logged in, a posting window will appear at the bottom of the messages. If you are not a member, please register for an account.
  • Posting is a two-step process. Once you have composed your message, you will be taken to the preview page. You will then have a chance to review your post, make changes and upload photos.
  • After posting your message, you may need to refresh the forum page in order to see it.
  • Before posting copyrighted material, please read about Copyright and Fair Use.
  • We have a strict no-advertising policy!
  • If you would like to practice posting or uploading photos, please visit our Test forum.
  • If you need assistance, please Contact Us and we will be happy to help.


Learn more about in-text links on this page here