Return to the Garages/Workshops Forum | Post a Follow-Up

 o
Chamberlain belt drive opener

Posted by patjnoble (My Page) on
Tue, May 29, 07 at 22:18

Hi everyone I'm new here and have a problem I hope someone can help me with. I purchased a new Chamberlain belt drive opener and installed it myself but when I tested it for the first time it started out ok but then started to make a binding noise and stopped half way and the unit started clicking for about five seconds. At first I thought there was something stopping the trolly but I didn't see anything that was abstructing it. Did skip a step or did I get a manual that was missing a page?
Please help!!!
Thanks in advance


Follow-Up Postings:

 o
RE: Chamberlain belt drive opener

Unusual problem. I suggest you can Chamberlain or the place you purchased it. They will help you with a new opener.


 o Post a Follow-Up

Please Note: Only registered members are able to post messages to this forum.

    If you are a member, please log in.

    If you aren't yet a member, join now!


Return to the Garages/Workshops Forum

Information about Posting

  • You must be logged in to post a message. Once you are logged in, a posting window will appear at the bottom of the messages. If you are not a member, please register for an account.
  • Please review our Rules of Play before posting.
  • Posting is a two-step process. Once you have composed your message, you will be taken to the preview page. You will then have a chance to review your post, make changes and upload photos.
  • After posting your message, you may need to refresh the forum page in order to see it.
  • Before posting copyrighted material, please read about Copyright and Fair Use.
  • We have a strict no-advertising policy!
  • If you would like to practice posting or uploading photos, please visit our Test forum.
  • If you need assistance, please Contact Us and we will be happy to help.


Learn more about in-text links on this page here