Return to the Garages/Workshops Forum | Post a Follow-Up

 o
air compressor help

Posted by acguy (My Page) on
Wed, May 14, 08 at 22:03

my air compressor stopped building air pressure the motor runs when the switch is turned on. i used it one day and worked great the very next day, i went to use it closed the petcock turned it on and it sounded funny and waited and watched the gauge and and there was no build up of pressure on the gauge thinking the gauge was broken i opened the pressure relief valve and there was no air in the tank. any ideas thanks


Follow-Up Postings:

 o
RE: air compressor help

My first guess would be a check valve between the pump and tank that is stuck in the unseated position.
My second guess would be a blown seal in the pump.
Hopefully your problem is a check valve that is easily accessable.


 o Post a Follow-Up

Please Note: Only registered members are able to post messages to this forum.

    If you are a member, please log in.

    If you aren't yet a member, join now!


Return to the Garages/Workshops Forum

Information about Posting

  • You must be logged in to post a message. Once you are logged in, a posting window will appear at the bottom of the messages. If you are not a member, please register for an account.
  • Posting is a two-step process. Once you have composed your message, you will be taken to the preview page. You will then have a chance to review your post, make changes and upload photos.
  • After posting your message, you may need to refresh the forum page in order to see it.
  • Before posting copyrighted material, please read about Copyright and Fair Use.
  • We have a strict no-advertising policy!
  • If you would like to practice posting or uploading photos, please visit our Test forum.
  • If you need assistance, please Contact Us and we will be happy to help.


Learn more about in-text links on this page here