Return to the Garages/Workshops Forum | Post a Follow-Up

 o
HELP!! With Old Sears Compressor!!

Posted by rangr90 (My Page) on
Tue, Mar 27, 07 at 16:23

I have a old Sears air compressor made in 1968 it has about a 40 gal tank and a twin piston pump with a centrifugal unloader on it. What it is doing is at about 100 psi it starts to labor and spit air out the filter nut on the centrifugal unloader. It always would run up to 150 psi and shut off without any problem. Does anyone know what would cause this problem?????
Thanks
Rangr90


Follow-Up Postings:

 o
RE: HELP!! With Old Sears Compressor!!

Check the manual. If you don't have it, it might be available at www.sears.com.
Ron


 o Post a Follow-Up

Please Note: Only registered members are able to post messages to this forum.

    If you are a member, please log in.

    If you aren't yet a member, join now!


Return to the Garages/Workshops Forum

Information about Posting

  • You must be logged in to post a message. Once you are logged in, a posting window will appear at the bottom of the messages. If you are not a member, please register for an account.
  • Posting is a two-step process. Once you have composed your message, you will be taken to the preview page. You will then have a chance to review your post, make changes and upload photos.
  • After posting your message, you may need to refresh the forum page in order to see it.
  • Before posting copyrighted material, please read about Copyright and Fair Use.
  • We have a strict no-advertising policy!
  • If you would like to practice posting or uploading photos, please visit our Test forum.
  • If you need assistance, please Contact Us and we will be happy to help.


Learn more about in-text links on this page here