Return to the Garages/Workshops Forum | Post a Follow-Up

 o
Light not working

Posted by rangrfn (My Page) on
Thu, Mar 21, 13 at 12:11

Light on Garage door opener does not light up when opening GDO.
Does not work from wall switch either, could cause be circuit board is defective?


Follow-Up Postings:

 o
RE: Light not working

Take the bulb out and try it in another fixture known to work first.

The vibration on most openers kills plain bulbs.

You need a 'rough service' or 'high vibration' bulb almost all the time.

The cheap 'rough service' bulbs just have a coating on the glass.

You need the bulb with the extra filament support.


 o
RE: Light not working

Bulbs are good, not burnt out.


 o
RE: Light not working

Lights are now working, I got another circuit board on E-BAY and the problem was the circuit board.


 o Post a Follow-Up

Please Note: Only registered members are able to post messages to this forum.

    If you are a member, please log in.

    If you aren't yet a member, join now!


Return to the Garages/Workshops Forum

Information about Posting

  • You must be logged in to post a message. Once you are logged in, a posting window will appear at the bottom of the messages. If you are not a member, please register for an account.
  • Please review our Rules of Play before posting.
  • Posting is a two-step process. Once you have composed your message, you will be taken to the preview page. You will then have a chance to review your post, make changes and upload photos.
  • After posting your message, you may need to refresh the forum page in order to see it.
  • Before posting copyrighted material, please read about Copyright and Fair Use.
  • We have a strict no-advertising policy!
  • If you would like to practice posting or uploading photos, please visit our Test forum.
  • If you need assistance, please Contact Us and we will be happy to help.


Learn more about in-text links on this page here