Return to the Fireplaces Forum | Post a Follow-Up

 o
Heat and Glo SL-750TR-DSI not lighting

Posted by minal (My Page) on
Thu, Dec 22, 11 at 17:51

Hello,

I have a heat and glo fireplace (SL-750TR-DSI). It has a wall switch and a blower. When I flip the switch it lights up and then turns off. What could be the problem? I opened the glass to clear the embers from the ports, so that they are next to the ports.

But now the fireplace does not light up. I did not move the logs so they are still in the right place. I found the manual for the heat and glo but it not specific for DSI, so does anyone the correct ember placement for this kind of model?

thanks.
MP


Follow-Up Postings:

 o Post a Follow-Up

Please Note: Only registered members are able to post messages to this forum.

    If you are a member, please log in.

    If you aren't yet a member, join now!


Return to the Fireplaces Forum

Information about Posting

  • You must be logged in to post a message. Once you are logged in, a posting window will appear at the bottom of the messages. If you are not a member, please register for an account.
  • Posting is a two-step process. Once you have composed your message, you will be taken to the preview page. You will then have a chance to review your post, make changes and upload photos.
  • After posting your message, you may need to refresh the forum page in order to see it.
  • Before posting copyrighted material, please read about Copyright and Fair Use.
  • We have a strict no-advertising policy!
  • If you would like to practice posting or uploading photos, please visit our Test forum.
  • If you need assistance, please Contact Us and we will be happy to help.


Learn more about in-text links on this page here