Return to the Fireplaces Forum | Post a Follow-Up

 o
Quada Fire Santa Fe Pellet Stove

Posted by mouser10 (My Page) on
Thu, Mar 18, 10 at 11:38

We have had our Santa Fe for two years, have been very happy with it, and it has been trouble free. Two months ago it started woofing on start up with a high flame and a very pungent smell (like soot or ash and heated metal). Once the blower comes on, the flame goes to a normal flame and the smell dissapates. I called the dealer and talked to the service dept and was told that the the air holes were clogged and needed cleaning and to set the pellet feed control rod at a lower feed level. First, let me till you that I am fanatic about cleaning this stove. I clean the ash pot(and air holes), glass, and heat exchange rods daily. I scrape and vacuum out the whole area. Once a month I take the bricks and baffle out and scrub the heat exchange rods with a scrub brush to clean off the ash residue. I then vacuum all areas. We have used Lignetics pellets from the beginning without any problems. So I cleaned the whole stove once again and lowered the pellet feed control. This did not solve the problem. Called the dealer again and now we have had the service people out four times to no avail. They checked the stove out thoughly and said that there was nothing wrong with it and that it was one of the cleanest stoves that they had seen and that the air holes were not plugged. We still have a large flame up upon starting, woofing, and that pungent burning ash, soot smell. Once the blower starts the flame returns to normal and the smell slowly dissaptes. This happens every time the fire starts so the smell is now thoughout the house at all times. The chimminy and all piping were cleaned at the end of October. Has anyone else experience this type of problem? And if so, how was it resolved?


Follow-Up Postings:

 o
RE: Quada Fire Santa Fe Pellet Stove

are pellet stoves easier to use than the traditional one?

Here is a link that might be useful: mens boots


 o Post a Follow-Up

Please Note: Only registered members are able to post messages to this forum.

    If you are a member, please log in.

    If you aren't yet a member, join now!


Return to the Fireplaces Forum

Information about Posting

  • You must be logged in to post a message. Once you are logged in, a posting window will appear at the bottom of the messages. If you are not a member, please register for an account.
  • Please review our Rules of Play before posting.
  • Posting is a two-step process. Once you have composed your message, you will be taken to the preview page. You will then have a chance to review your post, make changes and upload photos.
  • After posting your message, you may need to refresh the forum page in order to see it.
  • Before posting copyrighted material, please read about Copyright and Fair Use.
  • We have a strict no-advertising policy!
  • If you would like to practice posting or uploading photos, please visit our Test forum.
  • If you need assistance, please Contact Us and we will be happy to help.


Learn more about in-text links on this page here