Return to the Fireplaces Forum | Post a Follow-Up

 o
Gas FP won't light when hot

Posted by edbro (My Page) on
Mon, Jan 17, 11 at 13:57

I have a Monessen millivolt fireplace with a remote control. Recently, I've been having problems getting it to light. The pilot light works fine, I just can't get the main burners to light.

Through trial and error, I've noticed that if I turn it all the way off, cut the gas supply and let it cool then it will work fine again after lighting the pilot. But, if the pilot is lit already, even though the unit isn't hot, it will not turn on. Once I do get it running, the remote will turn it on/off several times before it quits working again. It isn't the remote as the On/Off switch has the same problems. Anything I can try?


Follow-Up Postings:

 o Post a Follow-Up

Please Note: Only registered members are able to post messages to this forum.

    If you are a member, please log in.

    If you aren't yet a member, join now!


Return to the Fireplaces Forum

Information about Posting

  • You must be logged in to post a message. Once you are logged in, a posting window will appear at the bottom of the messages. If you are not a member, please register for an account.
  • Please review our Rules of Play before posting.
  • Posting is a two-step process. Once you have composed your message, you will be taken to the preview page. You will then have a chance to review your post, make changes and upload photos.
  • After posting your message, you may need to refresh the forum page in order to see it.
  • Before posting copyrighted material, please read about Copyright and Fair Use.
  • We have a strict no-advertising policy!
  • If you would like to practice posting or uploading photos, please visit our Test forum.
  • If you need assistance, please Contact Us and we will be happy to help.


Learn more about in-text links on this page here