Return to the Embroidery Forum | Post a Follow-Up

 o
please help se-270d doesn't read card

Posted by tricialynn (My Page) on
Tue, Nov 14, 06 at 21:20

Hi everyone. You all sound so experienced with various sewing and embroidery machines and I'm really hoping that one of you can help me. I recently purchased a second-hand SE-270D and a second-hand PED Basic. The software is Version 1.0 The problem I'm having is that SE-270 won't recognize the card and I keep getting the "this card won't work with this machine" message. I can write a design to the card so the card appears to be working. Does anyone have a clue as to why this is happening? I am so upset that I can't transfer designs to use with my machine and could really use some advice. Thank you!!!


Follow-Up Postings:

 o
RE: please help se-270d doesn't read card

Hi tricialynn!
First make sure the designs you are putting on the card are no larger than 4x4 and are in PES format. Look at your settings on your PED Basic. Then try transferring just one design. If this doesn't work, go to www.brother.com follow the links for home embroidery, downloads, and get the update for the PED Basic. If I remember correctly, I had to uninstall my basic, then use their version to reinstall. It sounds scary, but is really easy. Go check out brother site if you haven't already!
Please let us know how it's going!I've had that machine almost a year now and love it!
Lisa


 o
RE: please help se-270d doesn't read card

tricialynn-
pe design does not read ped basic. (i learned that the hard way too) what you need is a patch that makes it work just fine :)
i have one for pe design 5, and have seen them here for pedesign 6 so i am sure there is one out ther for your version as well.


 o
RE: please help se-270d doesn't read card

I hope you got your problem solved. I had the same problem. I uninstalled the program first. I went to the Brother's web site and downloaded the updated version for the hardware driver for the PED. That solved the problem. When you buy designs make sure they are 4x4's. It works fine now.


 o Post a Follow-Up

Please Note: Only registered members are able to post messages to this forum.

    If you are a member, please log in.

    If you aren't yet a member, join now!


Return to the Embroidery Forum

Information about Posting

  • You must be logged in to post a message. Once you are logged in, a posting window will appear at the bottom of the messages. If you are not a member, please register for an account.
  • Please review our Rules of Play before posting.
  • Posting is a two-step process. Once you have composed your message, you will be taken to the preview page. You will then have a chance to review your post, make changes and upload photos.
  • After posting your message, you may need to refresh the forum page in order to see it.
  • Before posting copyrighted material, please read about Copyright and Fair Use.
  • We have a strict no-advertising policy!
  • If you would like to practice posting or uploading photos, please visit our Test forum.
  • If you need assistance, please Contact Us and we will be happy to help.


Learn more about in-text links on this page here