Return to the Embroidery Forum | Post a Follow-Up

 o
new herewitj problem

Posted by quilt2embroider (My Page) on
Thu, May 29, 08 at 22:20

Hi am new the forum and need some help. I have a Brother 6500, also a Janome 9000 and a janome 10001. here is my problem: When I use my rayon thread on my brother machine it sews a few seconds and breaks. I thought maybe it was the thread (ARC) but I tried the exact design on both my Janomes with the exact threads and it is fine. I have cleaned my machine several times even in the hard to get places, have changed needles, used a different thread stand, and it continuses to happen but just on my brother, can any one suggest anything it may be and how to fix the problem? thanks for any help


Follow-Up Postings:

 o
RE: new herewitj problem

I use ARC poly on my Brother with no problem but I have not used ARC rayon.


 o Post a Follow-Up

Please Note: Only registered members are able to post messages to this forum.

    If you are a member, please log in.

    If you aren't yet a member, join now!


Return to the Embroidery Forum

Information about Posting

  • You must be logged in to post a message. Once you are logged in, a posting window will appear at the bottom of the messages. If you are not a member, please register for an account.
  • Please review our Rules of Play before posting.
  • Posting is a two-step process. Once you have composed your message, you will be taken to the preview page. You will then have a chance to review your post, make changes and upload photos.
  • After posting your message, you may need to refresh the forum page in order to see it.
  • Before posting copyrighted material, please read about Copyright and Fair Use.
  • We have a strict no-advertising policy!
  • If you would like to practice posting or uploading photos, please visit our Test forum.
  • If you need assistance, please Contact Us and we will be happy to help.


Learn more about in-text links on this page here