Return to the Embroidery Forum | Post a Follow-Up

 o
Janome 350e

Posted by staceyhigh (My Page) on
Mon, Feb 8, 10 at 23:26

Please help me. I purchased a 350e and have had nothing but problems. I know this is not the norm and maybe I am expecting too much from it. Please advise.
Here is the issue:
EVERY time I use the preprogrammed letters there are what appear to be stitches skipped in the H Z A ETSP and a few other letters. I can send pictures. I have taken it back to the store to make sure that the tension is set right. Each time they tell me it is. Even the technician at the store says its the best that it can do. He said that I should get a marker to fill in the missing stitches!?
Is this true? Do other people have this same problem?
I can send you pictures of the problems.
Thank you very much!
stacey


Follow-Up Postings:

 o
RE: Janome 350e

NO NO NO! The machine sews beautifully. Take it back and refuse to move until you either get another machine or get this one fixed! No-one buys a good machine to paint in stitches. I don't think I've ever heard anything so absurd in my life!!!


 o
RE: Janome 350e

I own a Husqvarna Viking D2. The first year I had it I had no problems with embroidery. Loved my machine! After the one year check up with the technician I had trouble with the tension and alot of bobbin thread could be seen on top of the embroidery. I was so mad. I would have been better off not taking the machine in. I was told the machine was set back to factory settings. So now I fix it myself by using a little screwdriver and giving the bobbin case a quarter turn. It fixed the problem. I'll take it in for a yearly cleaning because it was soooo expensive but I'll never feel good about how it will come back to me. Take the machine in and have them work with you at the store until it works like it should. These machines are expensive and you should be happy, not ruining clothing items because of the poor embroidery outcome.


 o Post a Follow-Up

Please Note: Only registered members are able to post messages to this forum.

    If you are a member, please log in.

    If you aren't yet a member, join now!


Return to the Embroidery Forum

Information about Posting

  • You must be logged in to post a message. Once you are logged in, a posting window will appear at the bottom of the messages. If you are not a member, please register for an account.
  • Posting is a two-step process. Once you have composed your message, you will be taken to the preview page. You will then have a chance to review your post, make changes and upload photos.
  • After posting your message, you may need to refresh the forum page in order to see it.
  • Before posting copyrighted material, please read about Copyright and Fair Use.
  • We have a strict no-advertising policy!
  • If you would like to practice posting or uploading photos, please visit our Test forum.
  • If you need assistance, please Contact Us and we will be happy to help.


Learn more about in-text links on this page here