Return to the Electronics Forum | Post a Follow-Up

 o
Phillips Magnavox Model2540C221

Posted by kikoman (My Page) on
Wed, Dec 27, 06 at 19:07

Assistance Needed,

I have a Philips Magnavox T.V that upon power up I receive a bright screen with horizotal lines for approx. 5 seconds, then the t.v shut's down.

Philips Magnavox
Model# HD2530 C221
Serial# 51177355
Chassis# 25F800 7583
Date Code # 1310K02C
Manufactered Nov 2000

I followed the instructions I found within another thread and replaced the R3340 10 ohm 1/3w resistor with a new 10 ohm 1/2w resistor from Radio Shack, but the problem still exist. Looking for any additional tips or advise to fix the set.

Thanks in advance.......Kiko


Follow-Up Postings:

 o Post a Follow-Up

Please Note: Only registered members are able to post messages to this forum.

    If you are a member, please log in.

    If you aren't yet a member, join now!


Return to the Electronics Forum

Information about Posting

  • You must be logged in to post a message. Once you are logged in, a posting window will appear at the bottom of the messages. If you are not a member, please register for an account.
  • Posting is a two-step process. Once you have composed your message, you will be taken to the preview page. You will then have a chance to review your post, make changes and upload photos.
  • After posting your message, you may need to refresh the forum page in order to see it.
  • Before posting copyrighted material, please read about Copyright and Fair Use.
  • We have a strict no-advertising policy!
  • If you would like to practice posting or uploading photos, please visit our Test forum.
  • If you need assistance, please Contact Us and we will be happy to help.


Learn more about in-text links on this page here