Return to the Electronics Forum | Post a Follow-Up

 o
20' Magnavox 20MT 1331/17

Posted by rain233 (My Page) on
Sat, Dec 8, 07 at 17:03

Hi I'm new to the forum here. I have a 20" Magnavox 20MT 1331/17 which recently fell off a 3 foot stand on to the carpet. Now it won't turn on. There is no power light or anything. I opened it up but couldn't find any loose wire or anything obviously worng. Is there anything I can do to fix this or at least find out whats wrong? Thanks in advance guys, u guys r great.


Follow-Up Postings:

 o
RE: 20' Magnavox 20MT 1331/17

time to move down


 o
RE: 20' Magnavox 20MT 1331/17

any ideas? please. is there something i can do to test the circuit or something?


 o
RE: 20' Magnavox 20MT 1331/17

unanswered messages will eventually move down without anyone's help


 o Post a Follow-Up

Please Note: Only registered members are able to post messages to this forum.

    If you are a member, please log in.

    If you aren't yet a member, join now!


Return to the Electronics Forum

Information about Posting

  • You must be logged in to post a message. Once you are logged in, a posting window will appear at the bottom of the messages. If you are not a member, please register for an account.
  • Please review our Rules of Play before posting.
  • Posting is a two-step process. Once you have composed your message, you will be taken to the preview page. You will then have a chance to review your post, make changes and upload photos.
  • After posting your message, you may need to refresh the forum page in order to see it.
  • Before posting copyrighted material, please read about Copyright and Fair Use.
  • We have a strict no-advertising policy!
  • If you would like to practice posting or uploading photos, please visit our Test forum.
  • If you need assistance, please Contact Us and we will be happy to help.


Learn more about in-text links on this page here