Return to the Electronics Forum | Post a Follow-Up

 o
magnavox tv/vcr/dvd combo

Posted by bluismor69 (My Page) on
Mon, Dec 4, 06 at 12:54

Model Number MWC24T5 24 inch This TV is just a little over a year, used only about 5 times. It has no sound or pic. A repairman came to the house, said it was the power supply and replaced the part. TV worked for two days then the same thing happened. The same TV repairman came to the house and said that there was a wire loose, and tighten it. Another couple of days, the same thing no pic or sound. The same repairman came to the house, said he would have to take it in. He never came back and closed up shop. Through the Consumer Protection Agency I was able to get my TV back but with the same problem. Since it's not worth it to pay someone else to repair it nor is it worth it for me to file a law suit, I was wondering if anyone has any idea what the problem might be and/or what I can check for.


Follow-Up Postings:

 o Post a Follow-Up

Please Note: Only registered members are able to post messages to this forum.

    If you are a member, please log in.

    If you aren't yet a member, join now!


Return to the Electronics Forum

Information about Posting

  • You must be logged in to post a message. Once you are logged in, a posting window will appear at the bottom of the messages. If you are not a member, please register for an account.
  • Posting is a two-step process. Once you have composed your message, you will be taken to the preview page. You will then have a chance to review your post, make changes and upload photos.
  • After posting your message, you may need to refresh the forum page in order to see it.
  • Before posting copyrighted material, please read about Copyright and Fair Use.
  • We have a strict no-advertising policy!
  • If you would like to practice posting or uploading photos, please visit our Test forum.
  • If you need assistance, please Contact Us and we will be happy to help.


Learn more about in-text links on this page here