Return to the Electronics Forum | Post a Follow-Up

 o
philisps tv 30pw8420/37

Posted by benny_grower (My Page) on
Thu, Dec 6, 07 at 11:17

Hi,i've 30'hdtv philips it's was working well,but now doesn't turn on.just green led on front blink 20 to 25 times.Any code or idea to fix it?

Thanks.


Follow-Up Postings:

 o
RE: philisps tv 30pw8420/37

I have the service manual for chassis L05.1U in PDF.
If you need it email me.


 o
RE: philisps tv 30pw8420/37

Have had this TV for a year, now it turns on but theres no picture only static audio. Not sure if it puts out sound, after a few seconds it just shuts off. I am one broke ass college student who saved for a year to buy this piece of crap and now im back to a curved RCA no-def tv. I should have bought foreign. Anyone got any advice on how maybe I could fix this myself? Thanks


 o Post a Follow-Up

Please Note: Only registered members are able to post messages to this forum.

    If you are a member, please log in.

    If you aren't yet a member, join now!


Return to the Electronics Forum

Information about Posting

  • You must be logged in to post a message. Once you are logged in, a posting window will appear at the bottom of the messages. If you are not a member, please register for an account.
  • Please review our Rules of Play before posting.
  • Posting is a two-step process. Once you have composed your message, you will be taken to the preview page. You will then have a chance to review your post, make changes and upload photos.
  • After posting your message, you may need to refresh the forum page in order to see it.
  • Before posting copyrighted material, please read about Copyright and Fair Use.
  • We have a strict no-advertising policy!
  • If you would like to practice posting or uploading photos, please visit our Test forum.
  • If you need assistance, please Contact Us and we will be happy to help.


Learn more about in-text links on this page here